Project

General

Profile

Feature #956

Support for .MTS movie format

Added by Abhinav Badola about 5 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
video
Target version:
Start date:
22 May 2014
Due date:
% Done:

100%

Estimated time:

Description

Implement .MTS metadata read support.
Write support needs to be investigated and if possible implemented.

Feature has been requested and reported by Jim Shipman.

Reason - digiKam crashed while reading .MTS file.
Crash Report has been attached.
[1] http://dev.exiv2.org/attachments/610/digikam_crash_dump_05.txt


Related issues

Related to Exiv2 - Bug #961: Crash in digikam while reading metadata from a .MTS movie fileClosed08 Jun 2014

Actions

History

#1

Updated by Abhinav Badola about 5 years ago

Implement .MTS metadata read support.
Write support needs to be investigated and if possible implemented.

Feature has been requested and reported by Jim Shipman.

Reason - digiKam crashed while reading .MTS file.
Crash Report has been attached.

[1] http://dev.exiv2.org/attachments/610/digikam_crash_dump_05.txt

File that can be used for testing the bug-
[2] http://dev.exiv2.org/attachments/611/00056.MTS

#2

Updated by Phil Harvey about 5 years ago

Note that as far as I know the M2TS container format does not support metadata.

You must parse the embedded video stream if you want to extract any interesting information. :(

#3

Updated by Jim Shipman about 5 years ago

This is not a feature request. This should be a bug report, and it should have a high priority.

A file with a type unknown to exiv2 should simply return a failure code. Right now it totally crashes. Exiv2 should NEVER just crash. This crash makes digikam completely unusable to me.

Jim Shipman

#4

Updated by Robin Mills almost 5 years ago

  • Category changed from image format to xmp
  • Status changed from New to Assigned
  • Assignee set to Robin Mills
  • Priority changed from Low to Normal
  • Target version set to 0.25

I agree with Jim that Exiv2 should not crash. On Ubuntu 13.10 Exiv2 is throwing an exception. Perhaps Digikam does not have an exception handler to deal with this.

This is a duplicate of 961 and it is my mistake to have opened a second bug report about this.

#5

Updated by Robin Mills almost 5 years ago

  • Category changed from xmp to video
#6

Updated by Robin Mills almost 5 years ago

  • Status changed from Assigned to Resolved

I'm going to mark this as "resolved" and continue the discussion in #961. This issue will be closed during review in preparation for the 0.25 release.

#7

Updated by Gilles Caulier almost 5 years ago

Hi Robin,

digiKam itself do not have C++ exception, but it never use Exiv2 directly. For code design, all pass through libkexiv2, which is a C++ wrapper. All methods from libkexiv2 use C++ exception...

So typically, digiKam must never crash due to a C++ exception from Exiv2...

Gilles

#8

Updated by Robin Mills almost 5 years ago

Gilles.

I agree with you. I've moved this discussion and Topic #1737 to Issue #961. Easier for both of us to deal with this in a single place.

Robin

#9

Updated by Robin Mills about 4 years ago

  • % Done changed from 0 to 100
#10

Updated by Andreas Huggel almost 4 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF