Project

General

Profile

Bug #838

Regression: Visibility support disabled on Linux, when it should be enabled

Added by Andreas Huggel over 7 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Normal
Category:
build
Target version:
Start date:
20 Aug 2012
Due date:
% Done:

0%

Estimated time:

Description

On my trusted Debian system, the usual make config; ./configure --disable-shared reports

...

checking whether to enable dependency tracking... yes
checking whether to enable symbol visibility support...
checking whether to use the lens database for Nikon lens names... yes
...

------------------------------------------------------------------
-- Exiv2 0.23 feature configuration summary
--
-- Build a shared library......... NO
-- Use symbol visibility support.. NO
...

Visibility support is disabled, when it should - and used to be - on.

config.log is attached, it looks like the test for visibility support has no result (used to be 'yes', see e.g., gsoc2012 branch, which still works fine).


Files

config.log (47.9 KB) config.log Andreas Huggel, 20 Aug 2012 08:05

Associated revisions

Revision 2859 (diff)
Added by Robin Mills over 7 years ago

Fix for #838. Please see issue for my comments. Please close #838 if you agree it's fixed. If #838 is still broken, please push issue back to me.

History

#1

Updated by Robin Mills over 7 years ago

Andreas:

Fix submitted: SVN:2859.

Apologies for this. I had a typo in the spelling of visibility which turned it off on all platforms, when I only intended cygwin and mingw.

I've fixed the typos, however I'm not convinced that I have this right. If it's not fixed, can you revert to your original code in SVN:2685 I only submitted SVN:2776 for my convenience.

#2

Updated by Robin Mills over 7 years ago

  • Assignee changed from Robin Mills to Andreas Huggel
#3

Updated by Andreas Huggel over 7 years ago

  • Status changed from Assigned to Resolved
  • Assignee deleted (Andreas Huggel)

Looks good, thanks!

#4

Updated by Robin Mills over 6 years ago

  • Status changed from Resolved to Closed
  • Assignee set to Andreas Huggel

Fixed in 0.24.

Also available in: Atom PDF