Project

General

Profile

Bug #758

Exiv2 doesn't detect lens model in Pentax k-x DNG files

Added by Romain Henriet almost 9 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Low
Assignee:
-
Category:
exif
Start date:
08 Feb 2011
Due date:
% Done:

0%

Estimated time:

Description

I have DNG raw files created using Pentax K-x and exiv2 is not able to detect lens type.
exiftool IMGP0298.DNG | grep Lens gives the following result :

Lens Type : Tamron AF 17-50mm F2.8 XR Di-II LD (Model A16)
Lens F Stops : 7
Lens ID : Tamron AF 17-50mm F2.8 XR Di-II LD (Model A16)

Romain


Files

IMGP0298.DNG (13.3 MB) IMGP0298.DNG Sample file Romain Henriet, 08 Feb 2011 12:10

Related issues

Is duplicate of Exiv2 - Feature #574: Support "Adobe Makernote" in DNGPrivateDataNew

Actions

History

#1

Updated by Andreas Huggel almost 9 years ago

The Makernote of the sample image is in the Exif.Image.DNGPrivateData tag. Exiv2 doesn't decode this tag, see #574.

#2

Updated by Andreas Huggel almost 9 years ago

  • Category set to exif
#3

Updated by Andreas Huggel over 8 years ago

  • Status changed from New to Closed

Closed as "duplicate of #574".

Also available in: Atom PDF