Project

General

Profile

Bug #487

Crash in exiv2.exe (built with VC++ 2005 Express) when examing TIFF images

Added by Dimitri Schoolwerth almost 13 years ago. Updated over 10 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
build
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:

Description

When running exiv2.exe (with as parameter any TIFF image), there's a crash in tiffparser.cpp:154 (function TiffDecoder::findDecoder) while constructing TiffDecoderInfo::Key.

Additional information:

findDecoder's parameters are already invalid (make, extendedTag, group), and when simplifying the function to use a single unsigned int param it still has the wrong value. Perhaps there's a wrong forward (typedef) declaration somewhere?
Applying the attached patch fixes the problem (patch from within src/ )
The official exiv2.exe doesn't have this issue, nor does a local clean build on OS X (a patched build also still works correctly).


Files

tiffvisitor.cpp.patch (381 Bytes) tiffvisitor.cpp.patch Redmine Admin, 21 Sep 2006 08:10

History

#1

Updated by Andreas Huggel almost 13 years ago

Same problem with MSVC 7.1/2003. That was never tested because the regressions don't include any TIFF/RAW tests yet and MSVC builds receive minimum attention here...

Thanks a lot for reporting this and the fix in particular - it is totally beyond me. The only thing I notice is that the Tag and Group namespaces are in tiffcomposite.hpp. None of the compilers complains about anything though.

-ahu.

Also available in: Atom PDF