Project

General

Profile

Bug #955

Strange issue with Exif.CanonSi.Sequence

Added by Roman Lebedev about 5 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
metadata
Target version:
Start date:
23 Apr 2014
Due date:
% Done:

100%

Estimated time:

Description

According to Canon MakerNote Tags, tag Exif.CanonSi.Sequence is supposed to sequence number of images, taken in a continuous burst.
So i have taken 7 images (.CR2, taken on Canon EOS 550D with continuous shooting).
But neiher exiv2 nor exiftool does not show correct number in that tag:

$ exiv2 -v -u -pa *.CR2 |grep -i seq
IMG_9589.CR2          Exif.CanonSi.Sequence                       Short       1  0 num
IMG_9590.CR2          Exif.CanonSi.Sequence                       Short       1  0 num
IMG_9591.CR2          Exif.CanonSi.Sequence                       Short       1  0 num
IMG_9592.CR2          Exif.CanonSi.Sequence                       Short       1  0 num
IMG_9593.CR2          Exif.CanonSi.Sequence                       Short       1  0 num
IMG_9594.CR2          Exif.CanonSi.Sequence                       Short       1  0 num
IMG_9595.CR2          Exif.CanonSi.Sequence                       Short       1  0 num

Same result on shots taken with Canon EOS 5D Mark III.

Am i doing something wrong?
Is that field set incorrectly in the first place(i mean in camera)?
Is this a bug in exiv2? (i have already spent ~6 hours trying to debug this, so i am lost...)

Sample files: https://www.dropbox.com/sh/7ac7h754dvm1w4n/vi0f4UPNQp

History

#1

Updated by Phil Harvey about 5 years ago

This doesn't look like an Exiv2 problem. It seems the 5DmkIII doesn't write this information. Offhand, I can't say what models this is valid for, but apparently not for the 5DmkIII.

- Phil

#2

Updated by Robin Mills about 4 years ago

  • Category set to metadata
  • Status changed from New to Resolved
  • Assignee set to Phil Harvey
  • Target version set to 0.25

I'm going to mark this "Resolved" because of Phil's reply. The dropbox file is no longer available, so no further work is possible on this.

#3

Updated by Roman Lebedev about 4 years ago

Right, here is the updated link: https://www.dropbox.com/sh/w5fginww57ic4yl/AADP6OkXjF233gd9VmfbtYSaa?dl=0
I must say that i will be negatively surprised if Canon actually does not store such information in raws...

#4

Updated by Robin Mills about 4 years ago

Thanks, Roman. And thank you for providing those image so quickly.

This is interesting. Indeed the Sequence key is the same for consecutive images:

580 rmills@rmillsmbp:~/gnu/exiv2/trunk $ exiv2 -pa -g Sequence ~/Downloads/IMG_95*.CR2 
/Users/rmills/Downloads/IMG_9589.CR2  Exif.CanonSi.Sequence                        Short       1  0
/Users/rmills/Downloads/IMG_9590.CR2  Exif.CanonSi.Sequence                        Short       1  0
581 rmills@rmillsmbp:~/gnu/exiv2/trunk $ 
However there is timing information in the file that reveals the sequence.
585 rmills@rmillsmbp:~/gnu/exiv2/trunk $ exiv2 -pa ~/Downloads/IMG_9589.CR2 > 9589.txt
/Users/rmills/Downloads/IMG_9589.CR2: (No XMP data found in the file)
586 rmills@rmillsmbp:~/gnu/exiv2/trunk $ exiv2 -pa ~/Downloads/IMG_9590.CR2 > 9590.txt
/Users/rmills/Downloads/IMG_9590.CR2: (No XMP data found in the file)
587 rmills@rmillsmbp:~/gnu/exiv2/trunk $ diff 9589.txt 9590.txt 
9c9
< Exif.Image.StripByteCounts                   Long        1  420743
---
> Exif.Image.StripByteCounts                   Long        1  424433
13c13
< Exif.Image.DateTime                          Ascii      20  2014:04:20 21:16:02
---
> Exif.Image.DateTime                          Ascii      20  2014:04:20 21:16:03
22,23c22,23
< Exif.Photo.DateTimeOriginal                  Ascii      20  2014:04:20 21:16:02
< Exif.Photo.DateTimeDigitized                 Ascii      20  2014:04:20 21:16:02
---
> Exif.Photo.DateTimeOriginal                  Ascii      20  2014:04:20 21:16:03
> Exif.Photo.DateTimeDigitized                 Ascii      20  2014:04:20 21:16:03
70c70
< Exif.CanonSi.MeasuredEV                      Short       1  1.38
---
> Exif.CanonSi.MeasuredEV                      Short       1  1.25
80c80
< Exif.CanonSi.MeasuredEV2                     Short       1  1.38
---
> Exif.CanonSi.MeasuredEV2                     Short       1  1.12
131,133c131,133
< Exif.Photo.SubSecTime                        Ascii       3  96
< Exif.Photo.SubSecTimeOriginal                Ascii       3  96
< Exif.Photo.SubSecTimeDigitized               Ascii       3  96
---
> Exif.Photo.SubSecTime                        Ascii       3  27
> Exif.Photo.SubSecTimeOriginal                Ascii       3  27
> Exif.Photo.SubSecTimeDigitized               Ascii       3  27
149c149
< Exif.Thumbnail.JPEGInterchangeFormatLength   Long        1  970
---
> Exif.Thumbnail.JPEGInterchangeFormatLength   Long        1  972
155c155
< Exif.Image2.StripOffsets                     Long        1  468152
---
> Exif.Image2.StripOffsets                     Long        1  471844
161,162c161,162
< Exif.Image3.StripOffsets                     Long        1  2204856
< Exif.Image3.StripByteCounts                  Long        1  16406402
---
> Exif.Image3.StripOffsets                     Long        1  2208548
> Exif.Image3.StripByteCounts                  Long        1  16408041
588 rmills@rmillsmbp:~/gnu/exiv2/trunk $ 
It seems that the SubSecTime shows 3/27 and 3/96 which are 0.111 and 0.031. So the photos appear to be have been taken about 0.08 seconds apart.

Unless you can persuade me otherwise, I want to say "Not a bug". The Sequence key may be intended for this purpose, I can't see any evidence that it's been implemented on this model. If we're able to find images from a different model in which Sequence is being set, that would prove that Canon did not implement Sequence for this model.

#5

Updated by Robin Mills about 4 years ago

  • Assignee changed from Phil Harvey to Robin Mills
#6

Updated by Robin Mills about 4 years ago

  • % Done changed from 0 to 100
#7

Updated by Andreas Huggel almost 4 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF