Project

General

Profile

Bug #925

Reading XMP Data from Panasonic GX7 images crashed

Added by Christian Klinger over 5 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
xmp
Target version:
Start date:
10 Oct 2013
Due date:
% Done:

0%

Estimated time:

Description

Reading the images with exiv2 leads to a crash in the xmp section.
The Panasonic GX7 is a new camera on the market. I have also tried with a newer xmp sdk
from Adobe, but the software still crashes.


Files

iso_0800_25_256110.jpg (9.94 MB) iso_0800_25_256110.jpg Christian Klinger, 10 Oct 2013 10:37

History

#1

Updated by Robin Mills over 5 years ago

  • Status changed from New to Assigned
  • Priority changed from High to Normal
  • Target version set to 0.25

Thanks for sending this Christian. I'm not able to reproduce this on the trunk/exiv2-0.23/gsoc13 on the Mac.

Several questions:
1) Which platform (Mac/Windows/Linux)
2) Which version of exiv2 are you using?
3) Which build system ./configure/CMake/Visual Studio and compiler version?
4) I see you've assigned it 'High' priority. Can you say something to support giving it higher priority?

Robin

#2

Updated by Robin Mills over 5 years ago

  • Status changed from Assigned to Closed

Christian has emailed me privately about this.

Good news !
I have found the reason for the xmpsdk crash: It's not a software bug. Unfortunely the lib filename for the xmpsdk
is the same in release and debug versions. The compiler has found the release version first and linked it to my debug version.

So case closed. Thanks, Christian for letting me know.

Also available in: Atom PDF