Project

General

Profile

Bug #818

Wrong tag value for Nikon D50 / Vibration Reduction

Added by Meatball Destroyer over 7 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
exif
Target version:
Start date:
24 Mar 2012
Due date:
% Done:

100%

Estimated time:

Description

http://szal.electric-trick.org/albums/userpics/10001/DSC_2292_tar.gz

The camera and lens don't have vibration reduction.

exiv2 -p t 20120324_2292-680p.jpg | grep -i vibr
Exif.NikonSi02xx.VibrationReduction Byte 1 On (2)
Exif.NikonSi02xx.VibrationReduction1 Byte 1 (51)
Exif.NikonSi02xx.VibrationReduction2 Byte 1 n/a

exiv2 -p h 20120324_2292-680p.jpg | grep -i vibr
0x0075 NikonSi02xx VibrationReduction Byte 1 1
0x0082 NikonSi02xx VibrationReduction1 Byte 1 1
0x01ae NikonSi02xx VibrationReduction2 Byte 1 1

exiftool -H -a -u -g1 DSC_2292.NEF | grep -i vibr
0x01ae Vibration Reduction : n/a

Tested in exiv2-0.21.1 and exiftool-8.65


Files

DSC_2292.NEF (5.92 MB) DSC_2292.NEF Meatball Destroyer, 24 Mar 2012 13:28

History

#1

Updated by Robin Mills about 4 years ago

  • Status changed from New to Resolved
  • Assignee set to Robin Mills
  • Target version set to 0.25

I don't see a problem here. Exiv2 is correctly displaying the metadata in the the file:

585 rmills@rmillsmbp:~/gnu/exiv2/trunk $ exiv2 -pa -g Vibration ~/Downloads/DSC_2292.NEF  
Exif.NikonSi02xx.VibrationReduction          Byte        1  On (2)
Exif.NikonSi02xx.VibrationReduction1         Byte        1  (51)
Exif.NikonSi02xx.VibrationReduction2         Byte        1  n/a
586 rmills@rmillsmbp:~/gnu/exiv2/trunk $ exiftool ~/Downloads/DSC_2292.NEF | grep -i vib
Vibration Reduction             : n/a
587 rmills@rmillsmbp:~/gnu/exiv2/trunk $ 
That exiftool seems "sanitises" the output and only reports n/a is a feature of exiftool and not a bug in Exiv2.

#2

Updated by Robin Mills about 4 years ago

  • % Done changed from 0 to 100
#3

Updated by Andreas Huggel about 4 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF