Bug #763

Olympus E-510 RAW file (ORF) corrupted after geotagging

Added by Spica Han over 10 years ago. Updated over 5 years ago.

Target version:
Start date:
27 Feb 2011
Due date:
% Done:


Estimated time:
1.00 h


Hi all, I used exiv2-0.21.1 to add GPS info to my Olympus E-510 RAW files.
Exiv2 finished successfully. But the result files seem to be corrupted.
I tried to open them in Mac OS X 10.6.6 with Adobe Photoshop CS5 (Camera Raw 6.3),
and Camera Raw complained 'Could not complete your request because the file appears to be from a camera model which is not supported by the installed version of Camera Raw'.
I also tried with Aperture 3.1.1 and Preview, and they both failed to render the image.
The original files can be opened correctly.

The command I used for geotagging is
exiv2 -m geotag.cmd P9124985.ORF
Both geotag.cmd and P9124985.ORF sample are attached.

BTW, the above command works fine with Nikon NEF files.


P9124985.ORF (9.24 MB) P9124985.ORF Olympus E-510 RAW File Spica Han, 27 Feb 2011 01:33
geotag.cmd (670 Bytes) geotag.cmd Exiv2 geotag command script Spica Han, 27 Feb 2011 01:33



Updated by Robin Mills about 6 years ago

  • Target version set to 53

Updated by Robin Mills over 5 years ago

  • Category set to metadata
  • Status changed from New to Assigned
  • Assignee set to Robin Mills

This issue has been in the database for 5 years and nobody else has requested progress with this matter. So, unless you engage to persuade me to keep this matter alive, it will be closed on April 30 as "no longer needed/wanted".


Updated by Robin Mills over 5 years ago

  • Category changed from metadata to withdrawn
  • Status changed from Assigned to Closed
  • Target version changed from 53 to 0.26
  • % Done changed from 0 to 100
  • Estimated time set to 1.00 h

I can't open the file P9124985.ORF with Adobe PhotoShop Elements (nor with Exiv2). I can only assume that this is the "corrupted" file.

I've taken a good .ORF (which was provided to investigate #1178) and copied that to P9124985.ORF. The command file works perfectly.

562 rmills@rmillsmbp:~/Downloads $ exiv2 -pa --grep gps/i P9124985.ORF 
Exif.Image.GPSTag                            Long        1  1253058
Exif.GPSInfo.GPSVersionID                    Byte        4
Exif.GPSInfo.GPSVersionID                    Byte        4
Exif.GPSInfo.GPSLatitudeRef                  Ascii       2  North
Exif.GPSInfo.GPSLatitude                     Rational    3  36deg 33' 16.450" 
Exif.GPSInfo.GPSLongitudeRef                 Ascii       2  West
Exif.GPSInfo.GPSLongitude                    Rational    3  121deg 55' 47.050" 
Exif.GPSInfo.GPSAltitudeRef                  Byte        1  Above sea level
Exif.GPSInfo.GPSAltitude                     Rational    1  3.2 m
Exif.GPSInfo.GPSTimeStamp                    SRational   3  21:22:48
Exif.GPSInfo.GPSMapDatum                     Ascii       7  WGS-84
Exif.GPSInfo.GPSDateStamp                    SRational   3  2010/1 9/1 12/1
563 rmills@rmillsmbp:~/Downloads $ cat geotag.cmd 
add Exif.GPSInfo.GPSVersionID                Byte        2 0 0 0
add Exif.GPSInfo.GPSLatitudeRef              Ascii       N
add Exif.GPSInfo.GPSLatitude                 Rational    36/1 33/1 1645/100
add Exif.GPSInfo.GPSLongitudeRef             Ascii       W
add Exif.GPSInfo.GPSLongitude                Rational    121/1 55/1 4705/100
add Exif.GPSInfo.GPSAltitudeRef              Byte        0
add Exif.GPSInfo.GPSAltitude                 Rational    1986/625
add Exif.GPSInfo.GPSTimeStamp                SRational   21/1 22/1 48/1
add Exif.GPSInfo.GPSMapDatum                 Ascii       WGS-84
add Exif.GPSInfo.GPSDateStamp                SRational   2010/1 9/1 12/1
564 rmills@rmillsmbp:~/Downloads $ 
I'm going to mark the issue as close/withdrawn/v0.26.

Also available in: Atom PDF