Project

General

Profile

Bug #592

exiv2: Exif.Photo.UserComment unicode comment doesn't work

Added by Mark Purcell about 11 years ago. Updated almost 11 years ago.

Status:
Closed
Priority:
Normal
Category:
exif
Start date:
Due date:
% Done:

0%

Estimated time:

Description

From: matthieu castet <>
To: Debian Bug Tracking System <>
Subject: exiv2: Exif.Photo.UserComment unicode comment doesn't work
Date: Wed, 18 Jun 2008 20:53:27 +0200

Package: exiv2
Version: 0.16-4
Severity: normal

Hi,

Exif.Photo.UserComment unicode are store a utf-16 (big or little endian
according to the exif endianness). [1]

But exiv2 don't do any processing and output utf-16 on terminal.

Worse when setting UserComment with unicode charset, it write invalid
tag with the charset of your terminal.

Matthieu

[1]
$wget
http://castet.matthieu.free.fr/tmp/test_exif/IMG_0870_exiftool_usercomment_unicode.JPG
$exiv2 IMG_0870_exiftool_usercomment_unicode.JPG | grep "Exif comment" | hexdump -C
00000000 45 78 69 66 20 63 6f 6d 6d 65 6e 74 20 20 20 20 |Exif comment |
00000010 3a 20 00 75 00 6e 00 69 00 63 00 6f 00 64 00 65 |: .u.n.i.c.o.d.e|
00000020 00 20 00 74 00 65 00 73 00 74 00 20 00 3a 00 20 |. .t.e.s.t. .:. |
00000030 00 e9 00 e0 00 ea 0a |.


Related issues

Is duplicate of Exiv2 - Bug #562: Exif.Photo.UserComment unicode comment doesn't work (Debian bug #486884)Closed

Actions

History

#1

Updated by Andreas Huggel almost 11 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF