Project

General

Profile

Bug #411

Support non-standard Ifd layout

Added by Andreas Huggel over 14 years ago. Updated over 10 years ago.

Status:
Closed
Priority:
Normal
Category:
exif
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:

Description

The output from one popular program on the mac, GraphicConverter, seems to
created exif headers unreadable by exiv2. The interesting part is that other
programs, like Photoshop and iVew, can still successfully read the header.

The error message is:

"Offset of the 1st data entry of IFD0 is out of bounds:
Offset = 4294960962, exceeds buffer size by 4294960458 Bytes"

(Reported by Jeffrey J. Early)

Additional information:

The layout of IFD0 does not conform to that described in the Exif standard: The section containing tag data which occupies >4 bytes is before the IFD directory structure. However there is nothing technically wrong with the IFD, the problem is that class Exiv2::Ifd cannot handle negative offsets (relative to the start of the IFD).


Files

PIC_0325GC.jpg (48.4 KB) PIC_0325GC.jpg Redmine Admin, 10 Feb 2005 08:55

History

#1

Updated by Andreas Huggel over 14 years ago

r504 (trunk)
r505 (branches/Exiv2-0_6_041212)

Also available in: Atom PDF