Project

General

Profile

Support #1096

Exif.Image.Orientation only returns "1"

Added by Jason Best almost 4 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
not-a-bug
Target version:
Start date:
05 Aug 2015
Due date:
% Done:

100%

Estimated time:

Description

Exif.Image.Orientation only returns "1" no matter what the actual value is. I'm using version .25 on Ubuntu 14.04

exiv2 -K Exif.Image.Orientation test-small.JPG

Exif.Image.Orientation Short 1 right, top

exiv2 -M"set Exif.Image.Orientation 6" test-small.JPG

exiv2 -K Exif.Image.Orientation test-small.JPG

Exif.Image.Orientation Short 1 right, top

I've confirmed that "set Exif.Image.Orientation" works: the image is displayed with a new rotation and my image viewer (Preview on OS X) shows the updated orientation value in the metadata.


Files

test-small.JPG (14.3 KB) test-small.JPG Jason Best, 05 Aug 2015 17:46

History

#1

Updated by Alan Pater almost 4 years ago

The interpreted value is "right, top"

"1" refers to the number of characters the tag value is taking up.

#2

Updated by Jason Best almost 4 years ago

Oh wow, ok, stupid mistake on my part. I was expecting to set a value and get the same value back, but now I understand how this works. Looks like I don't have permissions to close this issue, but thanks for pointing this out.

#3

Updated by Alan Pater almost 4 years ago

  • Tracker changed from Bug to Support
  • Category set to not-a-bug
  • Status changed from New to Closed
  • Assignee set to Alan Pater
  • % Done changed from 0 to 100

No problem, that display threw me as well the first times I saw it.

Also available in: Atom PDF