Project

General

Profile

Bug #1094

Crash in Exiv2 shared lib

Added by Thomas T almost 4 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
makernote
Target version:
Start date:
19 Jul 2015
Due date:
% Done:

100%

Estimated time:
1.00 h

Description

I was told by Digikam development team to report my bug here. Please see link below for more information
https://bugs.kde.org/show_bug.cgi?id=350367
I attached the "faulty" image. I can't edit any picture taken from my personnal camera Casio EX-Z450. Work fine with other camera.

Exiv2 version : 0.25
libkexiv2 version : 2.4.0

Regards,


Files

CIMG1601.JPG (4.15 MB) CIMG1601.JPG Thomas T, 19 Jul 2015 12:33

Related issues

Is duplicate of Exiv2 - Bug #1106: Crash in exiv2 due to assertion when setting rating on jpg with a Casio makernoteClosed19 Aug 2015

Actions

History

#1

Updated by Robin Mills over 3 years ago

  • Category set to not-a-bug
  • Status changed from New to Closed
  • Assignee set to Robin Mills
  • Priority changed from High to Normal
  • Target version set to 0.25
  • % Done changed from 0 to 100
  • Estimated time set to 1.00 h

Cannot reproduce on Mac/Linux/Windows (Cygwin and MSVC)

766 rmills@rmillsmbp:~/gnu/exiv2/trunk $ exiv2 -pa http://dev.exiv2.org/attachments/download/803/CIMG1601.JPG
Exif.Image.Make                              Ascii      24  CASIO COMPUTER CO.,LTD.
Exif.Image.Model                             Ascii      12  EX-Z450    
Exif.Image.Orientation                       Short       1  top, left
Exif.Image.XResolution                       Rational    1  72
Exif.Image.YResolution                       Rational    1  72
Exif.Image.ResolutionUnit                    Short       1  inch
Exif.Image.Software                          Ascii      18  1.00             
Exif.Image.DateTime                          Ascii      20  2009:07:19 10:23:06
Exif.Image.YCbCrPositioning                  Short       1  Co-sited
Exif.Image.ExifTag                           Long        1  282
Exif.Photo.ExposureTime                      Rational    1  1/500 s
Exif.Photo.FNumber                           Rational    1  F5.8
Exif.Photo.ExposureProgram                   Short       1  Auto
Exif.Photo.ISOSpeedRatings                   Short       1  64
Exif.Photo.ExifVersion                       Undefined   4  2.21
Exif.Photo.DateTimeOriginal                  Ascii      20  2009:07:19 10:23:06
Exif.Photo.DateTimeDigitized                 Ascii      20  2009:07:19 10:23:06
Exif.Photo.ComponentsConfiguration           Undefined   4  YCbCr
Exif.Photo.CompressedBitsPerPixel            Rational    1  5.37259
Exif.Photo.ExposureBiasValue                 SRational   1  0 EV
Exif.Photo.MaxApertureValue                  Rational    1  F2.6
Exif.Photo.MeteringMode                      Short       1  Multi-segment
Exif.Photo.LightSource                       Short       1  Unknown
Exif.Photo.Flash                             Short       1  No, auto
Exif.Photo.FocalLength                       Rational    1  19.6 mm
Exif.Photo.MakerNote                         Undefined 8848  (Binary value suppressed)
Exif.MakerNote.Offset                        Long        1  768
Exif.MakerNote.ByteOrder                     Ascii       3  MM
Exif.Casio2.PreviewImageSize                 Short       2  640 480
Exif.Casio2.PreviewImageLength               Long        1  0
Exif.Casio2.PreviewImageStart                Long        1  0
Exif.Casio2.PreviewImage                     Undefined   0  
Exif.Casio2.FirmwareDate                     Ascii      18  2009:07:24 16:40
Exif.Casio2.WhiteBalanceBias                 Short       2  530 435
Exif.Casio2.WhiteBalance2                    Short       1  Daylight
Exif.Casio2.AFPointPosition                  Short       4  148 320 104 240
Exif.Casio2.ObjectDistance                   Long        1  Inf
Exif.Casio2.FlashDistance                    Short       1  0
Exif.Casio2.SpecialEffectMode                Byte        3  0 0 0
Exif.Casio2.FaceInfo                         Undefined 1216  (Binary value suppressed)
Exif.Casio2.RecordMode                       Short       1  2
Exif.Casio2.ReleaseMode                      Short       1  Normal
Exif.Casio2.Quality                          Short       1  Fine
Exif.Casio2.FocusMode2                       Short       1  Single-Area Auto Focus
Exif.Casio2.HometownCity                     Ascii      24  Paris
Exif.Casio2.BestShotMode                     Short       1  1
Exif.Casio2.AutoISO                          Short       1  On
Exif.Casio2.AFMode                           Short       1  Intelligent
Exif.Casio2.Sharpness2                       Undefined   2  0 0
Exif.Casio2.Contrast2                        Undefined   2  0 0
Exif.Casio2.Saturation2                      Undefined   2  0 0
Exif.Casio2.ISO                              Short       1  64
Exif.Casio2.ColorMode                        Short       1  Off
Exif.Casio2.Enhancement                      Short       1  Off
Exif.Casio2.ColorFilter                      Short       1  Off
Exif.Casio2.ArtMode                          Short       1  Normal
Exif.Casio2.SequenceNumber                   Short       1  0
Exif.Casio2.ImageStabilization               Short       2  0 3
Exif.Casio2.LightingMode                     Short       1  Shadow Enhance Low
Exif.Casio2.PortraitRefiner                  Short       1  Off
Exif.Casio2.SpecialEffectLevel               Short       1  0
Exif.Casio2.SpecialEffectSetting             Short       1  Off
Exif.Casio2.DriveMode                        Short       1  Single Shot
Exif.Photo.FlashpixVersion                   Undefined   4  1.00
Exif.Photo.ColorSpace                        Short       1  sRGB
Exif.Photo.PixelXDimension                   Long        1  4000
Exif.Photo.PixelYDimension                   Long        1  3000
Exif.Photo.InteroperabilityTag               Long        1  9616
Exif.Iop.InteroperabilityIndex               Ascii       4  R98
Exif.Iop.InteroperabilityVersion             Undefined   4  1.00
Exif.Photo.FileSource                        Undefined   1  Digital still camera
Exif.Photo.CustomRendered                    Short       1  Normal process
Exif.Photo.ExposureMode                      Short       1  Auto
Exif.Photo.WhiteBalance                      Short       1  Auto
Exif.Photo.DigitalZoomRatio                  Rational    1  1.7
Exif.Photo.FocalLengthIn35mmFilm             Short       1  112.0 mm
Exif.Photo.SceneCaptureType                  Short       1  Standard
Exif.Photo.GainControl                       Short       1  None
Exif.Photo.Contrast                          Short       1  Normal
Exif.Photo.Saturation                        Short       1  Normal
Exif.Photo.Sharpness                         Short       1  Normal
Exif.Image.PrintImageMatching                Undefined  46  80 114 105 110 116 73 77 0 48 51 48 48 0 0 0 5 0 1 0 22 0 22 0 2 1 0 0 0 1 0 5 0 0 0 1 1 1 0 0 0 1 16 131 0 0 0
Exif.Thumbnail.Compression                   Short       1  JPEG (old-style)
Exif.Thumbnail.XResolution                   Rational    1  72
Exif.Thumbnail.YResolution                   Rational    1  72
Exif.Thumbnail.ResolutionUnit                Short       1  inch
Exif.Thumbnail.JPEGInterchangeFormat         Long        1  9740
Exif.Thumbnail.JPEGInterchangeFormatLength   Long        1  7694
http://dev.exiv2.org/attachments/download/803/CIMG1601.JPG: (No XMP data found in the file)
767 rmills@rmillsmbp:~/gnu/exiv2/trunk $

#2

Updated by Thomas T over 3 years ago

I understand your answer but that was not what I was doing to have the bug. I tried to edit and save this picture with Digikam.
Based on the ticket from Digikam bug tracking I'm not the only having this issue. Please take a look at the backtrace in the original bug tracking ticket and comment from Gilles Caulier about It crash in Exiv2 shared lib in TIFF file parser.
https://bugs.kde.org/show_bug.cgi?id=350367

Can I do something to help you on this ? (I'm not a developper)

#3

Updated by Alan Pater over 3 years ago

I suspect this is the same issue as #1106 which has been fixed. Both involve saving changes to Casio images.

#4

Updated by Thomas T over 3 years ago

Indeed, looks very close to what I have. As I don't have the knowledge to recompile everything, I will wait for the next release.

#5

Updated by Andreas Huggel over 3 years ago

  • Category changed from not-a-bug to makernote

Yes, this is a duplicate of #1106 (or rather the other way around).

Also available in: Atom PDF