Project

General

Profile

Bug #1030

Samyang 14mm Pro lens recognition

Added by Martin Jones over 4 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Normal
Category:
metadata
Target version:
Start date:
15 Feb 2015
Due date:
14 Apr 2015
% Done:

0%

Estimated time:

Description

This lens seems to be recognised by default as a fisheye lens, however the 14mm from Samyang is a rectilinear lens.


Files

UFRawSamyang14mm.jpg (47.7 KB) UFRawSamyang14mm.jpg UFRaw screenshot. Niels Kristian Bech Jensen, 14 Apr 2015 03:23

History

#1

Updated by Niels Kristian Bech Jensen about 4 years ago

  • Category set to metadata
  • Status changed from New to Assigned
  • Assignee set to Niels Kristian Bech Jensen
  • Target version set to 0.26

Please attach or link to a sample image file. A small unmodified JPEG from the camera and lens in question will be fine.

Best regards,
Niels Kristian Bech Jensen

#2

Updated by Martin Jones about 4 years ago

Hello,

here a dropbox link. Please let me know once downloaded so I can delete the image accordingly.
Image is directly from the D7100 on smallest jpeg setting. Image size approx. 1.2mb

https://www.dropbox.com/s/plu4nbqna119a3y/DSC_3609.JPG?dl=0

Thanks
Martin

#3

Updated by Niels Kristian Bech Jensen about 4 years ago

Thank you for the file. I have downloaded it and will investigate the problem.

Best regards,
Niels Kristian Bech Jensen

#4

Updated by Martin Jones about 4 years ago

thanks for the confirmation. I look forward to your feedback.

Please note that the problem is apparent for me when importing NEF files into DARKTABLE. The lens correction module which uses the EXIV2 library reconises the lens as a fisheye by default. I then have to manually change each time to rectilinear.

Regards
Martin

#5

Updated by Niels Kristian Bech Jensen about 4 years ago

Neither I nor Robert Rottmerhusen can find anything wrong with the metadata in the JPEG. Could you please attach or link to a raw file so I can check if it is something specific to raw files or lensfun.

Best regards,
Niels Kristian Bech Jensen

#6

Updated by Martin Jones about 4 years ago

Hi Niels,
here a RAW file for you.

https://www.dropbox.com/s/63gufk0atu0pdch/DSC_3553.NEF?dl=0

Again, please let me know once downloaded.

Regards
Martin

#7

Updated by Niels Kristian Bech Jensen about 4 years ago

  • File UFRawSamyang14mm.jpg added
  • Due date set to 14 Apr 2015
  • Status changed from Assigned to Resolved
  • Target version changed from 0.26 to 0.25

Thank you for the raw file. I have checked it using UFRaw with both Exiv2 0.23/lensfun 0.2.8 and Exiv2 0.25 (current svn trunk)/lensfun 0.3.0. Both systems recognize the lens as rectilinear (see attached screenshot).

I mark this report as resolved.

Best regards,
Niels Kristian Bech Jensen

#8

Updated by Niels Kristian Bech Jensen about 4 years ago

  • File deleted (UFRawSamyang14mm.jpg)
#10

Updated by Martin Jones about 4 years ago

that is very strange. I use darktable and when I activate the lens correction module it Defaults to a fish-eye representation of the Image. Looks like I Need to contact the guys at darktable. In the future I will check the Image with UFraw and Rawtherapee.
thanks for your help

#11

Updated by Andreas Huggel almost 4 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF