Project

General

Profile

Bug #1018

Sigma 70mm f/2.8 EX DG Macro EF wrong LensModel

Added by Andreas Wicenec over 4 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Normal
Category:
metadata
Target version:
Start date:
04 Jan 2015
Due date:
10 Jan 2015
% Done:

100%

Estimated time:

Description

The Sigma 70mm f/2.8 EX DG Macro EF reports the wrong LensModel in the categories Canon and Photo. The CanonCs.LensType is correct. The reported LensModel is EF50mm f/2.5 Compact Macro +LSC.

I'm using exiv2 version 0.24 on Mac OSX 10.9.5


Files

IMG_2159.jpg (8.71 MB) IMG_2159.jpg Andreas Wicenec, 05 Jan 2015 16:28

History

#1

Updated by Niels Kristian Bech Jensen over 4 years ago

  • Status changed from New to Assigned
  • Assignee set to Niels Kristian Bech Jensen
  • Target version set to 0.25

Please attach a sample image file so I can reproduce the problem.

Best regards,
Niels Kristian Bech Jensen

#2

Updated by Andreas Wicenec over 4 years ago

Sure. Here you go.

#3

Updated by Niels Kristian Bech Jensen over 4 years ago

  • Due date set to 10 Jan 2015
  • Status changed from Assigned to Closed
  • % Done changed from 0 to 100

Thank you for the sample image. The LensModel tag is hardcoded in the image file:

nkbj@bohrium:~$ strings IMG_2159.jpg | grep +LSC
EF50mm f/2.5 Compact Macro +LSC
EF50mm f/2.5 Compact Macro +LSC

Third-party lens makers sometimes masquerade their lenses as similar OEM lenses. This is such a case.

I closed this bug report since this is not a bug.

Best regards,
Niels Kristian Bech Jensen

Also available in: Atom PDF