Project

General

Profile

Bug #1214

Human readable GPS values could be bad

Added by Ondřej Tůma over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
exif
Target version:
Start date:
26 Aug 2016
Due date:
% Done:

100%

Estimated time:
1.00 h

Description

The problem is in function printDegrees in tags.cpp file. GPS values is defined as unsignedRational, but printDegress read values to int32_t instead of uint32_t. That create bad values at the end of precision like: 49deg 21' -2.596" which is bad. The right value could be 49deg 21' 40.354".


Files

printDegrees.patch (645 Bytes) printDegrees.patch Ondřej Tůma, 26 Aug 2016 09:08

Associated revisions

Revision 4440 (diff)
Added by Robin Mills over 2 years ago

#1214 Patch submitted r4440. Thank You to Ondřej for reporting this and providing the patch.

History

#1

Updated by Robin Mills over 2 years ago

  • Status changed from New to Assigned
  • Assignee set to Robin Mills
  • Target version set to 0.26
  • % Done changed from 0 to 100
  • Estimated time changed from 0.10 h to 1.00 h

Patch submitted r4440. Thank You to Ondřej for reporting this and providing the patch.

I added a cast to your code because I suspect either the MSVC 64 or 32 bit build will need it.

#2

Updated by Robin Mills over 2 years ago

  • Status changed from Assigned to Closed

Also available in: Atom PDF