Project

General

Profile

Bug #1201

Rating=4 automatically added when writing sidecar

Added by Elfie Groslin over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
metadata
Target version:
Start date:
10 Aug 2016
Due date:
% Done:

100%

Estimated time:
2.00 h

Description

This behavior was observed when writing metadata to images with DigiKam. The bug seems to come from Exiv2 and I was asked to report it here instead.

The comment from the DigiKam developer was that when running this command:

exiv2 -eX 20160806-105555-NIKON-D300S.nef

Then even though the original image has no rating, the sidecar file is created with a rating of 4. He guesses this could be related to the tag Iptc.Application2.RecordVersion=4 in the image.

The test image can be found here:

https://www.dropbox.com/sh/3iven4s0jamu5m5/AAC_6Of-XkPQu4krf2FpLSSNa?dl=0

Thanks.

Associated revisions

Revision 4364 (diff)
Added by Alan Pater over 2 years ago

#1201 do not map Iptc.Application2.RecordVersion to Xmp.xmp.Rating

History

#1

Updated by Alan Pater over 2 years ago

  • Category set to metadata
  • Assignee set to Alan Pater
  • % Done changed from 0 to 50
  • Estimated time set to 2.00 h

Included in exiv2 as an explicit feature, not a bug.

Defacto norms are to map "Iptc.Application2.RecordVersion" to "Xmp.xmp.Rating". However, it may be that this defacto norm is wrong.

What is the justification for removing this mapping when it is expected by many users? Or is it expected?

#2

Updated by Elfie Groslin over 2 years ago

According to page 24 of the IPTC standard (https://www.iptc.org/std/IIM/4.1/specification/IIMV4.1.pdf), none of the tags in the Application Record No.2 section are mandatory, but if any is used then the Record Version is mandatory.

Here is the description of this tag:
A binary number identifying the version of the Information Interchange Model, Part II (Record 2:xx), utilised by the provider. Version numbers are assigned by IPTC and NAA. The version number of this record is four (4).

I am not sure why this ended up being mapped to Xmp.xmp.Rating?

Also on your wiki page here (http://dev.exiv2.org/projects/exiv2/wiki/The_Metadata_in_JPEG_files), example 2 under section 3.2 lists metadata from an image having the Iptc.Application2.RecordVersion tag set to 4 and a Xmp.xmp.Rating tag set to 0.

#3

Updated by Alan Pater over 2 years ago

  • Status changed from New to Assigned
  • Target version set to 0.26

Looking back, it seems you are correct. I can't find any documentation justifying this mapping. It will be fixed shortly ...

#4

Updated by Alan Pater over 2 years ago

  • Status changed from Assigned to Closed
  • % Done changed from 50 to 100

Also available in: Atom PDF