Project

General

Profile

Bug #521

Image with large invalid Exif tag crashes exiv2

Added by Andreas Huggel over 12 years ago. Updated almost 11 years ago.

Status:
Closed
Priority:
Normal
Category:
exif
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:

Description

Is it just me, or this JPEG file:

<http://farm2.static.flickr.com/1159/533197401_e0d2c40636_o.jpg>

causes exiv2 to crash and burn? I've just tried with version 0.14:

[hveravellir 12:33 ~/Downloads/exiv2-0.14/src] % ./exifprint /Users/
marco/Desktop/533197401_e0d2c40636_o.jpg
Warning: IFD0 tag 0x0000 has invalid Exif type 0; using 7 (undefined).
Warning: IFD1: Pointer to next IFD is out of bounds; ignored.
Warning: IFD1 tag 0x0000 has invalid Exif type 72; using 7 (undefined).
Warning: IFD1 tag 0x6f74 has invalid Exif type 28531; using 7 (undefined).
Segmentation fault

Reported by Marco Piovanelli.


Related issues

Related to Exiv2 - Bug #513: Sony Makernote crashes exiv2Closed

Actions

History

#1

Updated by Andreas Huggel over 12 years ago

The issue is related to #513, but not triggered by a Sony Makernote tag here. The size limit chosen to fix #513 was too large, the result is an out-of-memory situation when exiv2 tries to read the tag (IFD1 tag 0x0000, size 1097101154).

#2

Updated by Andreas Huggel over 12 years ago

r1133 (trunk)
r1134, 1136 (branches/unstable)

Also available in: Atom PDF