Project

General

Profile

Pentax lens not recognised

Added by S. Verdoold over 6 years ago

The "smc PENTAX-DA 18-135mm F3.5-5.6 ED AL [IF] DC WR" lens is also not recognised by exiv2:

exiv2 -pt IMGP4060.JPG | grep -i lens
Exif.Pentax.LensType Byte 4 Unknown (0x08d7)
Exif.Pentax.LensInfo Undefined 67 168 48 0 215 82 40 86 47 64 85 1 15 32 217 171 112 48 1 81 130 251 255 255 255 215 33 101 1 20 32 170 184 0 0 0 0 0 255 240 215 232 0 188 200 48 15 0 0 0 0 0 0 128 0 25 79 240 11 49 187 15 242 128 187 16 82 139

whereas it seems that exiftool does recognise it:

../Image-ExifTool-9.02/exiftool ./IMGP4060.DNG | grep -i lens
Lens Type : smc PENTAX-DA 18-135mm F3.5-5.6 ED AL [IF] DC WR
Lens F Stops : 6
Lens ID : smc PENTAX-DA 18-135mm F3.5-5.6 ED AL [IF] DC WR

I hope the above information already helps a bit in a possible fix. If more data or information is needed for a possible fix please let me know!


Replies (2)

RE: Pentax lens not recognised - Added by Robin Mills over 6 years ago

Hey S:

Has this matter now been answered with your patch?

Robin

RE: Pentax lens not recognised - Added by S. Verdoold over 6 years ago

Hey Robin,

The "Lens Type" is now correctly identified. The patch by Pascal de Bruijn already fixed that. (My patch simply adds to Pascals patch so I guess both should be applied). The LensInfo part is unchanged (and it would require more than just adding some ID's to change it I guess). The main point about the lens recognition has been answered by the patches however.

Sjaak

    (1-2/2)