Support #995

Writing Exif to TIFF-like Hasselblad RAW *.3fr

Added by Markus Diem over 2 years ago. Updated almost 2 years ago.

Status:ClosedStart date:04 Nov 2014
Priority:NormalDue date:
Assignee:Robin Mills% Done:

100%

Category:tiff parser
Target version:0.25

Description

hi,

we have tried writing exif data (e.g. orientation) to a TIFF-like RAW file (Hasselblad RAW *.3fr). There seem to be some issues while loading:
Warning: Directory SubImage1, entry 0x0111: Strip 0 is outside of the data area; ignored.
but the metadata is loaded correctly.
However, if we try saving some metadata to the file it gets corrupted. The bug can be reproduced with exiv2-0.23 and exiv2-0.24 (Win8 and Ubuntu 14.04). I have provided a sample image here (since it is too large to attach): ftp://scruffy.caa.tuwien.ac.at/staff/diem/sample-raw.zip
It would be cool if you could have a look at it.

regards,
markus


Related issues

Related to Exiv2 - Feature #992: Better raw file support and test Assigned 18 Sep 2014

History

#1 Updated by Robin Mills over 2 years ago

  • Tracker changed from Bug to Support
  • Category set to tiff parser
  • Status changed from New to Assigned
  • Assignee set to Robin Mills
  • Target version set to 0.25

From your description, it sounds as though your input file is suspect. Thanks for the sample file. I've recovered that without difficulty. I'm on vacation at the moment, so I'm not promising when I will investigate. Please let me know if this is urgent.

Robin

#2 Updated by Robin Mills about 2 years ago

  • Status changed from Assigned to Resolved

I've had a look at this. I'm currently adding a feature -pS to the exiv2 application to print the structure of files (currently implemented for JPEG, PNG and TIFF). I've had a look at your files:

1262 rmills@rmillsmbp:~/Downloads/sample-raw $ exiv2 -pS some-raw.3FR
STRUCTURE OF TIFF FILE: some-raw.3FR
 address |    tag                      |      type |    count |   offset | value
      10 | 0x00fe NewSubfileType       |      LONG |        1 |        1 | 1
      22 | 0x0100 ImageWidth           |     SHORT |        1 |      218 | 218
      34 | 0x0101 ImageLength          |     SHORT |        1 |      218 | 218
      46 | 0x0102 BitsPerSample        |     SHORT |        3 |      328 | 
      58 | 0x0103 Compression          |     SHORT |        1 |        1 | 1
      70 | 0x0106 PhotometricInterpret |     SHORT |        1 |        2 | 2
      82 | 0x010f Make                 |     ASCII |       11 |      336 | Hasselblad.
      94 | 0x0110 Model                |     ASCII |       21 |      348 | Hasselblad 500 mech..
     106 | 0x0111 StripOffsets         |      LONG |        1 |     2048 | 2048
     118 | 0x0112 Orientation          |     SHORT |        1 |        6 | 6
     130 | 0x0115 SamplesPerPixel      |     SHORT |        1 |        3 | 3
     142 | 0x0116 RowsPerStrip         |      LONG |        1 |      218 | 218
     154 | 0x0117 StripByteCounts      |      LONG |        1 |   142572 | 11500
     166 | 0x011a XResolution          |  RATIONAL |        1 |      372 | 
     178 | 0x011b YResolution          |  RATIONAL |        1 |      380 | 
     190 | 0x011c PlanarConfiguration  |     SHORT |        1 |        1 | 1
     202 | 0x0128 ResolutionUnit       |     SHORT |        1 |        2 | 2
     214 | 0x0131 Software             |     ASCII |       24 |      388 | 196.50.271.41.23.4.1.13.
     226 | 0x0132 DateTime             |     ASCII |       20 |      412 | 2007:06:03 12:22:55.
     238 | 0x014a SubIFDs              |      LONG |        1 |      432 | 432
     250 | 0x02bc XMLPacket            |      BYTE |       48 |      620 | <x:xmpmeta xmlns:x='adobe:ns:met ...
     262 | 0x8769 ExifTag              |      LONG |        1 |      668 | 668
     274 | 0xc614 UniqueCameraModel    |     ASCII |       13 |     1108 | Hasselblad96.
     286 | 0xc621 ColorMatrix1         | SRATIONAL |        9 |     1124 | 
     298 | 0xc628 AsShotNeutral        | SRATIONAL |        3 |     1196 | 
     310 | 0xc65d RawDataUniqueID      |      BYTE |       16 |     1220 | 03F0C73E000002B1
1263 rmills@rmillsmbp:~/Downloads/sample-raw $ exiv2 -pS ~/Downloads/sample-raw/some-raw-after-saving.3FR 
STRUCTURE OF TIFF FILE: /Users/rmills/Downloads/sample-raw/some-raw-after-saving.3FR
 address |    tag                      |      type |    count |   offset | value
      10 | 0x00fe NewSubfileType       |      LONG |        1 |        1 | 1
      22 | 0x0100 ImageWidth           |     SHORT |        1 |      218 | 218
      34 | 0x0101 ImageLength          |     SHORT |        1 |      218 | 218
      46 | 0x0102 BitsPerSample        |     SHORT |        3 |      314 | 
      58 | 0x0103 Compression          |     SHORT |        1 |        1 | 1
      70 | 0x0106 PhotometricInterpret |     SHORT |        1 |        2 | 2
      82 | 0x010f Make                 |     ASCII |       11 |      320 | Hasselblad.
      94 | 0x0110 Model                |     ASCII |       21 |      332 | Hasselblad 500 mech..
     106 | 0x0111 StripOffsets         |      LONG |        1 |     6862 | 6862
     118 | 0x0112 Orientation          |     SHORT |        1 |        3 | 3
     130 | 0x0115 SamplesPerPixel      |     SHORT |        1 |        3 | 3
     142 | 0x0116 RowsPerStrip         |      LONG |        1 |      218 | 218
     154 | 0x0117 StripByteCounts      |      LONG |        1 |   142572 | 11500
     166 | 0x011a XResolution          |  RATIONAL |        1 |      354 | 
     178 | 0x011b YResolution          |  RATIONAL |        1 |      362 | 
     190 | 0x011c PlanarConfiguration  |     SHORT |        1 |        1 | 1
     202 | 0x0128 ResolutionUnit       |     SHORT |        1 |        2 | 2
     214 | 0x0131 Software             |     ASCII |       24 |      370 | 196.50.271.41.23.4.1.13.
     226 | 0x0132 DateTime             |     ASCII |       20 |      394 | 2007:06:03 12:22:55.
     238 | 0x014a SubIFDs              |      LONG |        1 |      540 | 540
     250 | 0x8769 ExifTag              |      LONG |        1 |      722 | 722
     262 | 0xc614 UniqueCameraModel    |     ASCII |       13 |      414 | Hasselblad96.
     274 | 0xc621 ColorMatrix1         | SRATIONAL |        9 |      428 | 
     286 | 0xc628 AsShotNeutral        | SRATIONAL |        3 |      500 | 
     298 | 0xc65d RawDataUniqueID      |      BYTE |       16 |      524 | 03F0C73E000002B1
    1158 | 0x0103 Compression          |     SHORT |        1 |        6 | 6
    1170 | 0x0201 JPEGInterchangeForma |      LONG |        1 |     1198 | 1198
    1182 | 0x0202 JPEGInterchangeForma |      LONG |        1 |     5664 | 5664
1265 rmills@rmillsmbp:~/Downloads/sample-raw $ 
I'm going to mark this "resolved" as I there isn't much we can do at this time. exiv2 is reporting unhappiness with the file, and is having trouble saving the file.

However your issue isn't being forgotten or ignored because we have an open issue to improve our RAW file support. I've associated this report with the effort to improve our RAW support and your file will receive additional attention at some time in the future.

#3 Updated by Robin Mills about 2 years ago

  • Subject changed from Writing Exif to TIFF-like RAW to Writing Exif to TIFF-like Hasselblad RAW *.3fr

#4 Updated by Robin Mills almost 2 years ago

  • % Done changed from 0 to 100

#5 Updated by Andreas Huggel almost 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF

Redmine Appliance - Powered by TurnKey Linux