Bug #725

-DSUPPRESS_WARNINGS is kind of hokey

Added by Simson Garfinkel over 8 years ago. Updated over 8 years ago.

Status:ClosedStart date:02 Sep 2010
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-Estimated time:1.00 hour
Target version:-

Description

I'm having a problem with the -DSUPPRESS_WARNINGS mechanism.

libexiv2 is installed as a system-wide library. But some of my programs need to display warnings and others should not. The -DSUPPRESS_WARNINGS doesn't work with this use case.

Far better than compiling with warning suppression on or not would be to have a way of controlling the printing of warnings of a per-object basis. This could be done by changing the output stream (perhaps the output stream should be a pointer, which is usually &std::cerr but which could be made to be 0 to suppress errors).

Is there any interest in making this change? I would rather not keep my own private copy.


Related issues

Duplicates Exiv2 - Feature #614: silence warnings from code Closed 29 Jan 2009

History

#1 Updated by Andreas Huggel over 8 years ago

  • Status changed from New to Closed

Closing as duplicate of #614.

See #476 for the current idea to resolve this. This is a long overdue issue and I'd be happy if you decided to tackle it. (I think there is a sketch of what changes are needed somewhere, I'll see if I can find that.)

Andreas

Also available in: Atom PDF

Redmine Appliance - Powered by TurnKey Linux