Bug #1239

exiv2 0.25 crashes with casio ex-z50 files

Added by Rainer Kliese 12 months ago. Updated 12 months ago.

Status:ClosedStart date:02 Oct 2016
Priority:NormalDue date:
Assignee:Robin Mills% Done:

100%

Category:duplicateEstimated time:1.00 hour
Target version:0.26

Description

I discovered this bug first with digikam and opened a ticket "Bug 367913" on https://bugs.kde.org/.
Digikam crashes whenever it has to manipulate a file from casio ex-z50.
It worked before release of libexiv2.0.25. It occured with kubuntu 16.04 and worked with kubuntu 14.04. I have attached a file which cause the trouble.

This BUG on KDE was resoveld with status "resolved upstream" with the remark:
"You must reprot this problem to Exiv2 bugzilla, as you are able to reproduce the crash. Try to identify the file which crash application for futur investigations from Exiv2 team. Gilles Caulier"

That is why I open this ticket here.
Here are some observations:
starting: exiv2 ex a.jpg
results in:
exiv2: tiffcomposite.cpp:749: virtual Exiv2::Internal::TiffComponent* Exiv2::Internal::TiffMnEntry::doAddPath(uint16_t, Exiv2::Internal::TiffPath&, Exiv2::Internal::TiffComponent*, Exiv2::Internal::TiffComponent::AutoPtr): Zusicherung »mn_« nicht erfüllt.

Exiv2 version is:
@exiv2 0.25 001900 (64 bit build)
Copyright (C) 2004-2015 Andreas Huggel.

This program is free software; you can redistribute it and/or
modify it under the terms of the GNU General Public License
as published by the Free Software Foundation; either version 2
of the License, or (at your option) any later version.

This program is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
GNU General Public License for more details.

You should have received a copy of the GNU General Public
License along with this program; if not, write to the Free
Software Foundation, Inc., 51 Franklin Street, Fifth Floor,
Boston, MA 02110-1301 USA
exiv2=0.25.0
platform=linux
compiler=G++
bits=64
dll=1
debug=0
version=5.2.1 20151022
date=Oct 23 2015
time=16:27:10
svn=0
ssh=0
curl=0
id=$Id: version.cpp 3800 2015-05-08 22:26:36Z robinwmills $
executable=/usr/bin/exiv2
library=/usr/lib/x86_64-linux-gnu/libexiv2.so.14
library=/usr/lib/x86_64-linux-gnu/libstdc++.so.6
library=/lib/x86_64-linux-gnu/libgcc_s.so.1
library=/lib/x86_64-linux-gnu/libc.so.6
library=/lib/x86_64-linux-gnu/libz.so.1
library=/lib/x86_64-linux-gnu/libexpat.so.1
library=/lib/x86_64-linux-gnu/libdl.so.2
library=/lib/x86_64-linux-gnu/libm.so.6
library=/lib64/ld-linux-x86-64.so.2
have_regex=1
have_strerror_r=1
have_gmtime_r=1
have_inttypes=1
have_libintl=1
have_lensdata=1
have_iconv=1
have_memory=1
have_memset=1
have_lstat=1
have_stdbool=1
have_stdint=1
have_stdlib=1
have_strlib=0
have_strchr=1
have_strerror=1
have_strerror_r=1
have_strings_h=0
have_strtol=1
have_mmap=1
have_munmap=1
have_sys_stat=1
have_timegm=1
have_unistd_h=0
have_sys_mman=1
have_libz=0
have_xmptoolkit=1
have_bool=1
have_strings=1
have_sys_types=1
have_unistd=1
have_unicode_path=0
enable_video=0
enable_webready=0
@

I do not know what actions to do next, so that this bug could be fixed.
Please give me instruction when you need further actions from my side.

a.jpg - a.jpg an example which makes trouble (2.05 MB) Rainer Kliese, 02 Oct 2016 18:18

History

#1 Updated by Robin Mills 12 months ago

  • Category set to duplicate
  • Status changed from New to Closed
  • Assignee set to Robin Mills
  • Target version set to 0.26
  • % Done changed from 0 to 100
  • Estimated time set to 1.00

I think this is a duplicate of #1106 and #1181 and #1184 . Your file is working OK on the trunk.

544 rmills@rmillsmbp:~/gnu/exiv2/team/contrib/redmine $ exiv2 -ex --verbose --force http://dev.exiv2.org/attachments/download/1074/a.jpg
File 1/1: http://dev.exiv2.org/attachments/download/1074/a.jpg
545 rmills@rmillsmbp:~/gnu/exiv2/team/contrib/redmine $
#1239 and #1238 seem to identical, so I've deleted #1238.

Also available in: Atom PDF

Redmine Appliance - Powered by TurnKey Linux