Bug #1217

Missing values for Exif.CanonCs.ISOSpeed tag 0x0010

Added by Niccolo Rigacci 11 months ago. Updated 10 months ago.

Status:ClosedStart date:30 Aug 2016
Priority:NormalDue date:18 Sep 2016
Assignee:Niels Kristian Bech Jensen% Done:

100%

Category:makernoteEstimated time:1.00 hour
Target version:0.26

Description

Hi,
in my Canon PowerShot S120 I get several ISO speeds not listed in Exiv2 Canon MakerNote, here are the missing ones (relevant source file si src/canonmn.cpp):

    '(16509)': '125'
    '(16634)': '250'
    '(16704)': '320'
    '(16884)': '500'
    '(17024)': '640'
    '(17384)': '1000'
    '(17634)': '1250'
    '(18384)': '2000'
    '(18884)': '2500'
    '(20384)': '4000'
    '(21384)': '5000'
    '(22784)': '6400'
    '(24384)': '8000'
    '(26384)': '10000'
    '(29184)': '12800'

Associated revisions

Revision 4510
Added by Niels Kristian Bech Jensen 10 months ago

Fix issue #1217: Missing values for Exif.CanonCs.ISOSpeed tag 0x0010.

History

#1 Updated by Robin Mills 11 months ago

  • Category set to makernote
  • Target version set to 0.27

Thanks for reporting this, Niccolo. We're trying to get to feature complete Exiv2 v0.26 at the moment. I'm going to defer this for v0.27.

#2 Updated by Niels Kristian Bech Jensen 10 months ago

  • Due date set to 18 Sep 2016
  • Assignee set to Niels Kristian Bech Jensen
  • Target version changed from 0.27 to 0.26
  • % Done changed from 0 to 100
  • Estimated time set to 0.00

Simple addition of data. No need to postpone.

Best regards,
Niels Kristian Bech Jensen

#3 Updated by Niels Kristian Bech Jensen 10 months ago

  • Status changed from New to Resolved

#4 Updated by Robin Mills 10 months ago

  • Status changed from Resolved to Closed
  • Estimated time changed from 0.00 to 1.00

Thank You for dealing with this, Niels. I'm going to close this.

Also available in: Atom PDF

Redmine Appliance - Powered by TurnKey Linux