Bug #1196

Crash in OS X when writing metadata

Added by Taras Kushnir 11 months ago. Updated 11 months ago.

Status:ClosedStart date:04 Jul 2016
Priority:NormalDue date:
Assignee:Robin Mills% Done:

100%

Category:jpeg parserEstimated time:1.00 hour
Target version:0.26

Description

My users reported crash when trying to write metadata using 0.25 as a static library.

From my logs - additional related exception in the context or writeMetadata():
Call to `getxattr' failed: Bad address (errno = 14)

Selected details of map report:

Crashed Thread: 30 QThread

Exception Type: EXC_BAD_ACCESS (SIGSEGV)
Exception Codes: EXC_I386_GPFLT
Exception Note: EXC_CORPSE_NOTIFY

Thread 30 Crashed:: QThread
0 com.yourcompany.xpiks-qt 0x000000010aa25a8e Exiv2::XmpKey::key() const + 398
1 ??? 0x2f2e588b090cc999 0 + 3399752122886834585


Does that ring any bell for you? I would like to investigate that but I don't know where to start.

Report.txt Magnifier (92.7 KB) Taras Kushnir, 04 Jul 2016 11:17

History

#1 Updated by Robin Mills 11 months ago

  • Status changed from New to Closed
  • Assignee set to Robin Mills
  • % Done changed from 0 to 100
  • Estimated time set to 1.00

I believe this is a duplicate of #1152 and was fixed on the trunk in January 2016.

Also available in: Atom PDF

Redmine Appliance - Powered by TurnKey Linux