Bug #1184

digikam crash when importing Casio jpeg

Added by Roland Roberts about 1 year ago. Updated about 1 year ago.

Status:ClosedStart date:16 May 2016
Priority:NormalDue date:
Assignee:Robin Mills% Done:

100%

Category:tiff parserEstimated time:1.00 hour
Target version:0.26

Description

This only happens during import, if I copy files manually into digikam's album tree, digikam works fine. I reported the problem there initially, but they referred me here. This may be related to issue 1181 from my reading of that.

The digikam folks wrote this:

Sound like it crash in libexiv2 while parsing TIFF header from Casio JPEG files.

Please report this problem to Exiv2 team.

Gilles Caulier

And below is what I originally reported. I'm attaching one of my images as well.

The crash assistant won't load and even though I installed the debuginfo package, I'm not getting anything extra. And ulimit -c unlimited isn't getting me a core dump, so I've not got much to go on except the logs to the terminal (below).

[root@airy ~]# rpm -q digikam
digikam-4.14.0-7.fc23.x86_64
[root@airy ~]# uname -a
Linux airy.rlent.pnet 4.4.9-300.fc23.x86_64 #1 SMP Wed May 4 23:56:27 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

No, I am not running digikam as root....

Reproducible: Always

Steps to Reproduce:
1. Import > Card Readers > SD/MMC Card at ...
2. Select one or more images from preview window
3. Download > Download Selected
4. Select Album, click OK

Actual Results:
Crash....

Expected Results:
Load me images into the selected Album

2038 roland> digikam
loaded the Generic plugin
libpng warning: iCCP: known incorrect sRGB profile
digikam(4743) KWidgetItemDelegateEventListener::eventFilter: User of KWidgetItemDelegate should not delete widgets created by createItemWidgets!
digikam(4743) KWidgetItemDelegateEventListener::eventFilter: User of KWidgetItemDelegate should not delete widgets created by createItemWidgets!
digikam(4743) KWidgetItemDelegateEventListener::eventFilter: User of KWidgetItemDelegate should not delete widgets created by createItemWidgets!
digikam(4743) KWidgetItemDelegateEventListener::eventFilter: User of KWidgetItemDelegate should not delete widgets created by createItemWidgets!
digikam(4743) KWidgetItemDelegateEventListener::eventFilter: User of KWidgetItemDelegate should not delete widgets created by createItemWidgets!
digikam(4743) KWidgetItemDelegateEventListener::eventFilter: User of KWidgetItemDelegate should not delete widgets created by createItemWidgets!
digikam(4743) KWidgetItemDelegateEventListener::eventFilter: User of KWidgetItemDelegate should not delete widgets created by createItemWidgets!
digikam(4743) KWidgetItemDelegateEventListener::eventFilter: User of KWidgetItemDelegate should not delete widgets created by createItemWidgets!
digikam(4743) KWidgetItemDelegateEventListener::eventFilter: User of KWidgetItemDelegate should not delete widgets created by createItemWidgets!
digikam(4743) KWidgetItemDelegateEventListener::eventFilter: User of KWidgetItemDelegate should not delete widgImport > Card Readers > SD/MMC Card at ...ets created by createItemWidgets!
digikam(4743) KWidgetItemDelegateEventListener::eventFilter: User of KWidgetItemDelegate should not delete widgets created by createItemWidgets!
digikam(4743) KWidgetItemDelegateEventListener::eventFilter: User of KWidgetItemDelegate should not delete widgets created by createItemWidgets!
digikam(4743) KWidgetItemDelegateEventListener::eventFilter: User of KWidgetItemDelegate should not delete widgets created by createItemWidgets!
digikam(4743) KWidgetItemDelegateEventListener::eventFilter: User of KWidgetItemDelegate should not delete widgets created by createItemWidgets!
libpng warning: iCCP: profile 'ICC Profile': 1000000h: invalid rendering intent
digikam(4743)/digikam (core) Digikam::ImageInfo::fromLocalFile: No location could be retrieved for "/run/media/roland/CASIO-DSC/DCIM/100CASIO/CIMG1238.JPG"
digikam(4743)/digikam (core) Digikam::ImageInfo::fromLocalFile: No location could be retrieved for "/run/media/roland/CASIO-DSC/DCIM/100CASIO/CIMG1245.JPG"
digikam: tiffcomposite.cpp:749: virtual Exiv2::Internal::TiffComponent* Exiv2::Internal::TiffMnEntry::doAddPath(uint16_t, Exiv2::Internal::TiffPath&, Exiv2::Internal::TiffComponent*, Exiv2::Internal::TiffComponent::AutoPtr): Assertion `mn_' failed.
QSocketNotifier: Invalid socket 15 and type 'Read', disabling...
QSocketNotifier: Invalid socket 18 and type 'Read', disabling...
QSocketNotifier: Invalid socket 21 and type 'Read', disabling...
digikam: Fatal IO error 9 (Bad file descriptor) on X server :0.
KCrash: Application 'digikam' crashing...
KCrash: Attempting to start /usr/libexec/kde4/drkonqi from kdeinit
KCrash: Connect sock_file=/home/roland/.kde/socket-airy.rlent.pnet/kdeinit4__0

(digikam:4743): GStreamer-CRITICAL **: gstsystemclock: write control failed in wakeup_async: 9:Bad file descriptor

(digikam:4743): GStreamer-CRITICAL **: gstsystemclock: write control failed in wakeup_async: 9:Bad file descriptor

Unable to start Dr. Konqi

CIMG1242.JPG (8.01 MB) Roland Roberts, 16 May 2016 21:11


Related issues

Related to Exiv2 - Bug #1181: Casio.jpg exports crash darktable - suse leap 42.1 Closed 27 Apr 2016
Related to Exiv2 - Bug #1106: Crash in exiv2 due to assertion when setting rating on jp... Closed 19 Aug 2015

History

#1 Updated by Robin Mills about 1 year ago

  • Category set to tiff parser
  • Status changed from New to Closed
  • Assignee set to Robin Mills
  • Target version set to 0.26
  • % Done changed from 0 to 100
  • Estimated time set to 1.00

I believe this is a duplicate of #1106 and #1181. Exiv2 is working OK with your on the trunk.

517 rmills@rmillsmbp:~/gnu/exiv2/trunk $ exiv2 --verbose --version --grep svn 
exiv2 0.25 001900 (64 bit build)
svn=4302
518 rmills@rmillsmbp:~/gnu/exiv2/trunk $ exiv2 -pa --grep Model http://dev.exiv2.org/attachments/download/1003/CIMG1242.JPG
Exif.Image.Model                             Ascii      12  EX-H20G    
519 rmills@rmillsmbp:~/gnu/exiv2/trunk $ 
It is possible to download our trunk build and patch your system, however this may disturb other applications which use libexiv2. A modified version of exiv2 v0.25 is "in the works" for Linux distribution thanks to the splendid work of Pascal de Bruijn from DarkTable. http://dev.exiv2.org/issues/1181#note-5

Also available in: Atom PDF

Redmine Appliance - Powered by TurnKey Linux