Bug #1158

GPSVersionID is allowed to store more than 4 bytes.

Added by Robin Mills over 1 year ago. Updated over 1 year ago.

Status:ClosedStart date:27 Jan 2016
Priority:NormalDue date:
Assignee:Robin Mills% Done:

100%

Category:metadataEstimated time:1.00 hour
Target version:0.26

History

#1 Updated by Robin Mills over 1 year ago

  • Status changed from Assigned to Resolved
  • % Done changed from 0 to 80
  • Estimated time set to 1.00

This was reported by private email from Mikayel Egibyan.

Not a bug! Exiv2 is not a policeman. You can set any tag to any value. I strongly encourage you to stick to the standard and set GPSVersionID to 4 bytes.

The Exif Specification defines GPSVersionID as a 4 byte tag. Section 4.6.6 p68. http://www.cipa.jp/std/documents/e/DC-008-2012_E.pdf

There is documentation on exiv2.org: http://www.exiv2.org/tags.html

0x0000 0 GPSInfo Exif.GPSInfo.GPSVersionID Byte Indicates the version of <GPSInfoIFD>. The version is given as 2.0.0.0. This tag is mandatory when <GPSInfo> tag is present. (Note: The <GPSVersionID> tag is given in bytes, unlike the <ExifVersion> tag. When the version is 2.0.0.0, the tag value is 02000000.H).

#2 Updated by Robin Mills over 1 year ago

  • Status changed from Resolved to Closed
  • % Done changed from 80 to 100

Also available in: Atom PDF

Redmine Appliance - Powered by TurnKey Linux