Bug #1100

Unable to extract preview for a remote image

Added by Robin Mills over 2 years ago. Updated about 2 years ago.

Status:ClosedStart date:09 Aug 2015
Priority:NormalDue date:
Assignee:Robin Mills% Done:

100%

Category:basicioEstimated time:2.00 hours
Target version:0.26

Description

This is easy to reproduce:

$ exiv2 -pp http://dev.exiv2.org/attachments/download/805/DSC_7154.jpg
Preview 1: image/jpeg, 160x120 pixels, 10837 bytes
$ exiv2 -ep1 http://dev.exiv2.org/attachments/download/805/DSC_7154.jpg
exiv2: Overwrite `http://dev.exiv2.org/attachments/download/805/DSC_7154-preview1.jpg'? y
Exiv2 exception in extract action for file http://dev.exiv2.org/attachments/download/805/DSC_7154.jpg:
http://dev.exiv2.org/attachments/download/805/DSC_7154-preview1.jpg: Failed to open file (wb): No such file or directory (errno = 2)
$ 
It appears that exiv2 uses the image path to create the preview path. However for a remote file, this will usually fail because the remote server will normally be unable to create files. The user probably wants the preview to be created as a local file.

Associated revisions

History

#1 Updated by Robin Mills over 2 years ago

  • Category set to basicio
  • Status changed from New to Assigned
  • Assignee set to Robin Mills
  • Target version set to 0.26

#2 Updated by Robin Mills about 2 years ago

Fix submitted: r3897

#3 Updated by Robin Mills about 2 years ago

  • Status changed from Assigned to Closed

#4 Updated by Robin Mills about 2 years ago

$ exiv2 --verbose -pp http://dev.exiv2.org/attachments/download/805/DSC_7154.jpg
File 1/1: http://dev.exiv2.org/attachments/download/805/DSC_7154.jpg
Preview 1: image/jpeg, 160x120 pixels, 10837 bytes
$ exiv2 --verbose -ep --force http://dev.exiv2.org/attachments/download/805/DSC_7154.jpg
File 1/1: http://dev.exiv2.org/attachments/download/805/DSC_7154.jpg
Writing preview 1 (image/jpeg, 160x120 pixels, 10837 bytes) to file DSC_7154-preview1.jpg
$ ls -alt DSC_7154-preview1.jpg 
-rw-r--r--@ 1 rmills  staff  10837 26 Aug 14:40 DSC_7154-preview1.jpg
$ 

#5 Updated by Robin Mills about 2 years ago

  • % Done changed from 0 to 100
  • Estimated time set to 2.00

Also available in: Atom PDF

Redmine Appliance - Powered by TurnKey Linux