Bug #1099

mv: cannot stat 't-bs.gmo': No such file or directory

Added by Jakub Wilk almost 2 years ago. Updated about 1 year ago.

Status:ClosedStart date:08 Aug 2015
Priority:NormalDue date:
Assignee:Robin Mills% Done:

100%

Category:buildEstimated time:3.00 hours
Target version:0.26

Description

If you don't have gettext installed at configure time, make fails with an unclear error message:

make[2]: Entering directory '/home/jwilk/exiv2/po'
: --update bs.po exiv2.pot
rm -f bs.gmo && : -c --statistics -o bs.gmo bs.po
mv: cannot stat 't-bs.gmo': No such file or directory
Makefile:128: recipe for target 'bs.gmo' failed
make[2]: *** [bs.gmo] Error 1

(Tested with svn revision 3885.)

Associated revisions

Revision 4049
Added by Robin Mills over 1 year ago

#1099. Fix submitted.

History

#1 Updated by Robin Mills almost 2 years ago

  • Category set to build
  • Status changed from New to Assigned
  • Assignee set to Robin Mills
  • Target version set to 0.26

#2 Updated by Robin Mills over 1 year ago

  • Estimated time set to 3.00

#3 Updated by Robin Mills over 1 year ago

Which distribution are you using?

I use kubuntu (and cygwin and mingw) and gettext is there by default. Difficult to reproduce because I can't easily remove gettext because its a dependency of other pre-installed packages.

rmills@rmillsmbp-k1504:~/gnu/exiv2/trunk$ uname -a
Linux rmillsmbp-k1504 3.19.0-30-generic #34-Ubuntu SMP Fri Oct 2 22:08:41 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
rmills@rmillsmbp-k1504:~/gnu/exiv2/trunk$ apt-cache pkgnames | grep libgettext
libgettext-commons-java
libgettextpo-dev
libgettextpo0
libgettext-ant-tasks-java
libgettext-ocaml-dev
libgettext-ocaml
rmills@rmillsmbp-k1504:~/gnu/exiv2/trunk$ 

#4 Updated by Jakub Wilk over 1 year ago

I'm using Debian unstable.

I meant the gettext command-line tools (in package gettext), not gettext libraries.

#5 Updated by Robin Mills over 1 year ago

  • % Done changed from 0 to 50

Fix submitted r4049.

Jakub:

I've fixed this by adding code to config/configure.ac to test that gettext (and msgmerge etc) are on the path. If these utilities are not on the path, NLS will be disabled. So, you'll have to regenerate your configure script to use the fix:

$ svn update .
make config
./configure
make clean
make
Please let me know if this is OK for you. I haven't looked at the CMake scripts to see how/if they deal with this.

#6 Updated by Jakub Wilk over 1 year ago

Looks good to me, thanks!

#7 Updated by Robin Mills over 1 year ago

  • Status changed from Assigned to Resolved
  • % Done changed from 50 to 100

Thanks, Jakub. I'm marking this 100%/Resolved. If nothing else surfaces concerning this, I'll close it at the end of February.

Jakub: Can you have a look at #1102. I'm stuck with that. Can we progress #1102, or close it. Let me know.

#8 Updated by Robin Mills about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF

Redmine Appliance - Powered by TurnKey Linux