Bug #1097

Cannot write GPS coordinates to Canon CR2 files

Added by Meisam FS about 2 years ago. Updated almost 2 years ago.

Status:ClosedStart date:08 Aug 2015
Priority:NormalDue date:
Assignee:Alan Pater% Done:

100%

Category:not-a-bugEstimated time:2.00 hours
Target version:0.26

Description

I am using digikam to manage my photos, which works great for the most part except for one thing, it cannot save GPS coordinates to Canon CR2 files. The problem is the Exiv2 does not support writing GPS coordinates to CR2 files.

I'd like to see this feature added to Exiv2. I don't know if this is a limitation of CR2 files or just a missing feature in Exiv2. If it's the later, I'd like to contribute a patch to fix this. Any pointers to where I should start is really appreciated.

History

#1 Updated by Alan Pater about 2 years ago

What versions of digikam and of the exiv2 library are you using?

#2 Updated by Alan Pater about 2 years ago

Works for me:

~$ exiv2 -M'set Exif.GPSInfo.GPSLongitudeRef E' test.cr2

~$ exiv2 -M'set Exif.GPSInfo.GPSLongitude 16/1 16/1 16/1' test.cr2

~$ exiv2 -g GPS test.cr2 
Exif.Image.GPSTag                            Long        1  82428
Exif.GPSInfo.GPSLongitudeRef                 Ascii       2  East
Exif.GPSInfo.GPSLongitude                    Rational    3  16deg 16' 16" 

#3 Updated by Robin Mills almost 2 years ago

  • Category changed from api to not-a-bug
  • Status changed from New to Closed
  • Assignee set to Alan Pater
  • Target version set to 0.26
  • % Done changed from 0 to 100
  • Estimated time set to 2.00

Thank You, Alan for investigating this. I'm going to close this "not a bug".

Also available in: Atom PDF

Redmine Appliance - Powered by TurnKey Linux