Patch #1044

Parse TIFF PageNumber

Added by Robin Mills over 2 years ago. Updated over 2 years ago.

Status:ClosedStart date:24 Mar 2015
Priority:NormalDue date:
Assignee:Robin Mills% Done:

100%

Category:tiff parser
Target version:0.25

Description

http://dev.exiv2.org/boards/3/topics/1929

Thomas, can you please review this, discuss it with Mario and give me your assessment. And of course if you have a patch, please attach it to this issue. As Mario has been kind enough to provide a test file, we should also consider updating the test suite to take advantage of that file.

T1044.patch Magnifier (1.42 KB) Thomas Beutlich, 24 Mar 2015 20:09

Associated revisions

Revision 3632
Added by Robin Mills over 2 years ago

#1044. Thank you Mario for reporting this an providing a patch. Thank You for Thomas for validating this fix.

Revision 3640
Added by Robin Mills over 2 years ago

#1044. Test: regression detector.

History

#1 Updated by Thomas Beutlich over 2 years ago

Yes, patch works as expected. I could not apply the provided Exif.Image.PageNumber.patch but needed to manually patch it. New patch T1044.patch should hopefully work.

Thank you, Mario and Robin!

#2 Updated by Mario Emmenlauer over 2 years ago

Thanks for the great (and very fast) work, Thomas and Robin! Two thumbs up!

#3 Updated by Robin Mills over 2 years ago

Submitted r3632. Thank You, Mario for reporting this and providing the patch. Thank You, Thomas for validating the patch.

#4 Updated by Thomas Beutlich over 2 years ago

  • Assignee changed from Thomas Beutlich to Robin Mills

Back to Robin for the optional test case. I have no idea how to do it since I do not run the test suite.

#5 Updated by Robin Mills over 2 years ago

Mario

Is there any reason why we cannot copy your test file into our test suite (for example copyright). If you're OK with this, I'll add your file to the test suite tomorrow as a regression detector.

#6 Updated by Mario Emmenlauer over 2 years ago

Dear Robin and all, yes I agree, please use the file I sent in your test collection and anywhere else in development where you see fit! No copyright restrictions apply (as long as the predominant use is to aid in your development).
Thanks again and all the best!

#7 Updated by Robin Mills over 2 years ago

  • Status changed from Assigned to Resolved

Thanks Mario. Test suite updated: r3640. Good teamwork. Thanks Everybody.

#8 Updated by Robin Mills over 2 years ago

  • % Done changed from 0 to 100

#9 Updated by Andreas Huggel over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF

Redmine Appliance - Powered by TurnKey Linux