Patch #972

Update Panasonic EXIF Information

Added by Bernd Steinhauser almost 3 years ago. Updated 10 months ago.

Status:ClosedStart date:20 Jul 2014
Priority:NormalDue date:08 Sep 2014
Assignee:Niels Kristian Bech Jensen% Done:

100%

Category:metadata
Target version:0.25

Description

Based on the information available at [1] and based on the output of the images of my Panasonic Lumix DMC-G6, I wrote a patch for exiv2 updating the tags that I know of.
The second patch gets rid of a few duplicate entries which I'm not sure why they would be necessary, I can't see it.

Note that I broke compatibility with a few older cameras, since Panasonic doesn't seem to care too much about backwards compatibility (i.e. contrast mode entry), but I thought it would be better to stick to current models rather than antique ones.

0001-Update-exif-tag-information-for-Panasonic-cameras.patch Magnifier (31.6 KB) Bernd Steinhauser, 20 Jul 2014 10:20

0002-Remove-duplicate-entries-no-idea-why-they-would-be-n.patch Magnifier (2.78 KB) Bernd Steinhauser, 20 Jul 2014 10:20

Associated revisions

Revision 3357
Added by Niels Kristian Bech Jensen over 2 years ago

Fix issues #929 and #972: Improve Panasonic makernotes support. Thanks goes to numerous people for patches and input.

History

#1 Updated by Robin Mills almost 3 years ago

  • Category set to metadata
  • Status changed from New to Assigned
  • Assignee set to Niels Kristian Bech Jensen
  • Target version set to 0.25

Bernd

Thanks for sending the patches. I'm going to assign this issue to Niels because he's our maker notes engineer.

Robin

#2 Updated by Bernd Steinhauser almost 3 years ago

Bernd Steinhauser wrote:

Based on the information available at [1]

Sorry, forgot the reference:
[1] http://www.sno.phy.queensu.ca/~phil/exiftool/TagNames/Panasonic.html

#3 Updated by T Modes over 2 years ago

This is a duplicate of ticket #929

Also accelerometer settings and derived angles (pitch, roll) are only displayed as raw values and not the correctly converted values.

#4 Updated by Bernd Steinhauser over 2 years ago

Yes, I noticed that the output isn't in degrees, but I wasn't sure how to handle it.

I'll take a look at the other patch and test it. If I have any comments, I'll post them in the other bug report. You can close this as a duplicate.

#5 Updated by Niels Kristian Bech Jensen over 2 years ago

  • Due date set to 08 Sep 2014
  • Status changed from Assigned to Resolved
  • % Done changed from 0 to 100

#6 Updated by Andreas Huggel almost 2 years ago

  • Status changed from Resolved to Closed

#7 Updated by Thomas Beutlich 10 months ago

  • Subject changed from Update Panasoic EXIF Information to Update Panasonic EXIF Information

Also available in: Atom PDF

Redmine Appliance - Powered by TurnKey Linux