Patch #954

patch: support for Exif.CanonFi.FocusDistanceUpper and Exif.CanonFi.FocusDistanceLower

Added by Roman Lebedev over 3 years ago. Updated about 2 years ago.

Status:ClosedStart date:11 Apr 2014
Priority:NormalDue date:17 Apr 2014
Assignee:Niels Kristian Bech Jensen% Done:

100%

Category:metadata
Target version:0.25

Description

This adds Exif.CanonFi.FocusDistanceUpper and Exif.CanonFi.FocusDistanceLower tags

exiv2-Exif_CanonFi_FocusDistance.patch Magnifier (3.99 KB) Roman Lebedev, 11 Apr 2014 08:10

Associated revisions

Revision 3254
Added by Niels Kristian Bech Jensen over 3 years ago

Issue #954: Add support for Exif.CanonFi.FocusDistanceUpper and Exif.CanonFi.FocusDistanceLower. Thanks goes to Roman Lebedev for the patch.

History

#1 Updated by Niels Kristian Bech Jensen over 3 years ago

  • Due date set to 17 Apr 2014
  • Category set to metadata
  • Status changed from New to Resolved
  • Assignee set to Niels Kristian Bech Jensen
  • Target version set to 0.25
  • % Done changed from 0 to 100

Hi Roman.

Thanks for the patch. I have commited it to the svn trunk.

Best regards,
Niels Kristian Bech Jensen

#2 Updated by Roman Lebedev about 3 years ago

Follow up: looks like this regressed something:

$ exiv2 DSC_1985.NEF
... some normal output ...
Subject distance: Exiv2 exception in print action for file DSC_1985.NEF:
Invalid tag name or ifdId `FocusDistanceLower', ifdId 22
$

DSC_1985.NEF is not mine, so i can not upload it, but i believe it will reproduce with any file.

#3 Updated by Andreas Huggel about 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF

Redmine Appliance - Powered by TurnKey Linux