Bug #863

Unicode issue writing to XMP sidecar

Added by Marcel Wiesweg over 4 years ago. Updated almost 2 years ago.

Status:ClosedStart date:23 Oct 2012
Priority:NormalDue date:
Assignee:Alan Pater% Done:

100%

Category:xmp
Target version:0.25

Description

Writing dc.title or dc.description to an XMP sidecar file destroys non-ASCII characters.
This was originally reported for digikam writing to an XMP sidecar file using the library: https://bugs.kde.org/show_bug.cgi?id=304187
It is reproducible using the attached, prepared image file and the exiv2 command line utility:

Execute
exiv2 -eX empty-file.jpg

Inspect the two files:

exiv2 -p x empty-file.jpg
Xmp.dc.title LangAlt 1 lang="x-default" UnicoƉe
Xmp.dc.description LangAlt 1 lang="x-default" UnicoƉe

exiv2 -p x empty-file.xmp
Xmp.dc.title LangAlt 1 lang="x-default" Unico?e
Xmp.dc.description LangAlt 1 lang="x-default" Unico?e

Hexeditor confirms that the two-byte code 0xC689 becomes 0x3F, which is the question mark, in the file, indicating that a conversion process prior to writing the file fails, it's not a matter of reading or of display in the terminal.

empty-image.jpg (13.1 KB) Marcel Wiesweg, 23 Oct 2012 13:15

883.exiv2.jpg - test image digikam 4.8.0 / exiv2 0.24 (17.9 KB) Alan Pater, 08 Apr 2015 19:14

History

#1 Updated by Alan Pater about 2 years ago

  • File 883.exiv2.jpg added
  • Category set to xmp
  • Status changed from New to Resolved

I cannot reproduce this issue with a new test image that has had Title and Caption added by digikam 4.8.0 / exiv2 0.24.

~$ exiv2 -p x 883.exiv2.xmp
Xmp.dc.title                                 LangAlt     1  lang="x-default" UnicoƉe
Xmp.dc.description                           LangAlt     1  lang="x-default" UnicoƉe

#2 Updated by Robin Mills about 2 years ago

  • Assignee set to Alan Pater
  • Target version set to 0.25

#3 Updated by Alan Pater almost 2 years ago

  • % Done changed from 0 to 100

#4 Updated by Andreas Huggel almost 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF

Redmine Appliance - Powered by TurnKey Linux