Patch #843

Complete Samsung NX lenses portfolio recognition

Added by Jaroslav Stepanek about 5 years ago. Updated about 4 years ago.

Status:ClosedStart date:31 Aug 2012
Priority:NormalDue date:
Assignee:Robin Mills% Done:

100%

Category:exif
Target version:0.24

Description

Here is an updated version including the remaining two missing lenses (18-200mm and 85mm).
Names rewritten to match http://www.dpreview.com/products/Samsung/lenses?sort=chronological&view=grid

samsungmn.patch Magnifier (1.26 KB) Jaroslav Stepanek, 31 Aug 2012 11:12

99_pending_samsungmn.diff Magnifier - Updated patch (1.33 KB) Pascal de Bruijn, 26 Dec 2012 12:01

History

#1 Updated by Pascal de Bruijn about 5 years ago

May I ask how you identified the other remaining lenses? Do you have samples?

BTW, by changing some of these lens names it means it has to be changed in Lensfun too, which I could take care of, when this patch is applied.

#2 Updated by Jaroslav Stepanek about 5 years ago

Hello,
I downloaded samples from a Czech photo review web. 18-200mm: http://download.digimanie.cz/clanky/2012_03_28_Samsung_18_200mm/gallery2.SRW 85mm F1.4: http://download.digimanie.cz/clanky/2012_03_30_Samsung_85mm_F14/gallery1.SRW - careful, files are big. I checked the output with the current version for numbers and compiled the patched version for a last check (it works...).

I also submitted this list to exiftool but the "NX" was apparently left out of the names which I don't completely agree with (https://rt.cpan.org/Public/Bug/Display.html?id=79395). There were Samsung branded Pentax DSLR lenses in the past (D-Xenon). These are lenses for the NX system so why leave the NX out? On the other hand, from what I can see in the sources, neither exiv2 nor exiftool handle the old Samsung DSLR system (which was a clone of Pentax) separately.

I think that the exiv2 and exiftool lens databases should be kept in sync for things like Lensfun to work properly and that the Lensfun database should be updated according to the exiv2/exiftool names. I also looked at the Lensfun database recently and I think I saw only two lenses (30mm pancake and 20-50mm zoom). I have a NX10 and a 30mm plus the kit 18-55mm zoom for which I'd like to make a profile as soon as I have some spare time.

I also had an idea if we could identify the iFn versions somehow. The info might be in comparing firmware versions of non iFn and newer iFn lenses. If nothing else, we can see the firmware version in EXIF which identifies the lens. I'm not sure if such information is realy important... Maybe it is even possible to hack an iFn firmware to work with a older non iFn lens, but that's another discussion.

Samsung is planning new lenses for the NX but nothing has come out yet. Let's see what this year's Photokina will bring.

I'd be happy to maintain the Samsung NX lenses database if there isn't someone doing it already.

#3 Updated by Pascal de Bruijn about 5 years ago

Ah sweet, I've seen searching myself silly to get samples to complement this lens database... You beat me to the punch. Great!

I've talked to Phil too, making the same argument, I agree that adding NX will prevent any future confusion (regardless of what is and will be supported in the future).

I did the 20-50mm and 30mm lensfun correction models, it would be great to have the 18-55 added.

BTW, I already submitted a patch to the lensfun patch tracker about this change:
https://developer.berlios.de/patch/index.php?func=detailpatch&patch_id=3335&group_id=9034

As I said, I was already trying to complete this database but you beat me to the punch, I guess if we both keep an eye out we should be able to keep this database fairly up to date together :)

If all goes well I'll be visiting Photokina, I'm hoping I'll be able to try some of the soon to be released lenses there.

#4 Updated by Pascal de Bruijn almost 5 years ago

I haven't been able to get samples at Photokina...

But it seems Jaroslav did get some newer lens:

http://dev.exiv2.org/issues/872

Please do commit these patches.

#6 Updated by Robin Mills over 4 years ago

SVN: #2958. Thanks Jaroslav and Pascal for the discovery/patches/solution.

I'm rather confused because I don't know what those tables mean! However I've submitted what I believe you wish to see changed. Please review #2958 and confirm that I've done as you have requested.

I expect Andreas will want to review this change as he know how the data in this submission is used in the library.

I see two changes in particular:

1) Changing the names of every lens. For example:
Samsung Zoom 18-55mm F3.5-5.6 OIS -> Samsung NX 18-55mm F3.5-5.6 OIS

This will have consequences for applications which use the library.

2) Sequence:

        {  9, N_("Samsung NX 85mm F1.4 ED SSA")           },
        { 12, N_("Samsung NX 12-24mm F4-5.6 ED")          }

Why is the new lens not 10?

Robin

#7 Updated by Robin Mills over 4 years ago

  • Status changed from New to Feedback
  • Assignee set to Robin Mills

#8 Updated by Jaroslav Stepanek over 4 years ago

I can confirm that #2958 is correct.

Is there a need for testing using the real photos?

Why is the new lens not 10?

Difficult question... Samsung announced more lenses in the past, some of which got cancelled later on. There are unreleased lenses and the 45mm prime that isn't available yet. It seems the 12-24mm was just ready sooner than lenses with IDs 10 and 11;-)

#9 Updated by Robin Mills over 4 years ago

Thanks for confirming the submission and for your thoughts about the ID being 12. That all makes sense.

I'll download the image you suggested and test our code. If I can downsample the image and preserve the metadata (with samples/metacopy), I will extend our test suite.

Best Wishes for 2013.

Robin

#10 Updated by Robin Mills over 4 years ago

  • Status changed from Feedback to Resolved

#11 Updated by Robin Mills about 4 years ago

  • Status changed from Resolved to Closed

Fixed in 0.24.

Also available in: Atom PDF

Redmine Appliance - Powered by TurnKey Linux