Bug #827

Bug with Nikon D300 NEF - Exiv v.025 / 64 bits

Added by Vv Pz over 5 years ago. Updated over 1 year ago.

Status:ClosedStart date:22 May 2012
Priority:NormalDue date:
Assignee:Alan Pater% Done:

100%

Category:withdrawnEstimated time:2.00 hours
Target version:0.26

Description

Hi guys,

I recently ran into a bug using dartable on ubuntu when developping NEF files from my Nikon D300. According to one of the devs, it comes from exiv2.

----
$ exiv2 DSC_3912.NEF
Error: Directory (Last IFD item) with 4372 entries considered invalid; not read.
Warning: Unsupported date format
Warning: Unsupported time format
Warning: Unsupported date format
Warning: Unsupported time format
Warning: Unsupported date format
Warning: Unsupported time format
Warning: Unsupported date format
Warning: Unsupported time format
File name : DSC_3912.NEF
File size : 21906252 Bytes
MIME type : image/x-nikon-nef
Image size : 4352 x 2868
Camera make : NIKON CORPORATION
Camera model : NIKON D300
Image timestamp : 2009:05:09 11:45:10
Image number :
Exposure time : 1/800 s
Aperture : F5
Exposure bias : 0 EV
Flash : No flash
Flash bias :
Focal length : 12.0 mm (35 mm equivalent: 18.0 mm)
Subject distance:
ISO speed : 200
Exposure mode : Aperture priority
Metering mode : Multi-segment
Macro mode :
Image quality : RAW
Exif Resolution : 212 x 320
White balance : AUTO
Thumbnail : None
Copyright :
Exif comment :
----

You can find a NEF file that allow to reproduce the bug here :
https://skydrive.live.com/redir.aspx?cid=b448a5ee615d9f92&page=self&resid=B448A5EE615D9F92!109&parid=B448A5EE615D9F92!107&authkey=!ApEwJg3laBbWsio&Bpub=SDX.SkyDrive&Bsrc=Share

Pascal de Bruijn (from darktable's team) has made a short video related to this bug :
http://files.pcode.nl/temp/darktable-10-nikon-d300-bug.ogv

Please tell me if you need additional information.

Cheers,

Vv

Captura de pantalla de 2015-09-06 18_43_31.png (718 KB) Alan Pater, 06 Sep 2015 23:58

History

#1 Updated by Robin Mills over 2 years ago

  • Target version set to 53

#2 Updated by Alan Pater about 2 years ago

  • File Captura de pantalla de 2015-09-06 18_43_31.png added
  • Subject changed from Bug with Nikon D300 NEF - Exiv v.022 / 64 bits to Bug with Nikon D300 NEF - Exiv v.025 / 64 bits
  • Category set to makernote
  • Target version changed from 53 to 0.26

The video explaining the issue is no longer online. I found what appears to be original darktable bug report which says: "When I try to edit some raw files (from my Nikon D300), they appear all blurred with strangely colored stripes in darkroom mode .."
https://sourceforge.net/p/darktable/mailman/message/29222042/

The sample image did not appear strange on my system with darktable 1.6.8 and exiv2 0.25. Are there specific editing steps which resulted in the strangeness?

However, the "Unsupported Date/Time" issues still exist along with a message ignoring SubImage1.

$ exiv2 -g Time DSC_3912.NEF 
Warning: Directory SubImage1 has an unexpected next pointer; ignored.
Warning: Unsupported date format
Warning: Unsupported time format
Warning: Unsupported date format
Warning: Unsupported time format
Warning: Unsupported date format
Warning: Unsupported time format
Warning: Unsupported date format
Warning: Unsupported time format
Exif.Image.DateTime                          Ascii      20  2009:06:07 16:33:18
Exif.Photo.ExposureTime                      Rational    1  1/800 s
Exif.Photo.DateTimeOriginal                  Ascii      20  2009:05:09 11:45:10
Exif.Photo.DateTimeDigitized                 Ascii      20  2009:05:09 11:45:10
Exif.NikonWt.Timezone                        SShort      1  UTC +01:00
Exif.Photo.SubSecTime                        Ascii       3  43
Exif.Photo.SubSecTimeOriginal                Ascii       3  43
Exif.Photo.SubSecTimeDigitized               Ascii       3  43
Exif.Image.DateTimeOriginal                  Ascii      20  2009:05:09 11:45:10
Iptc.Envelope.TimeSent                       String      0  
Iptc.Application2.ReleaseTime                String      0  
Iptc.Application2.ExpirationTime             String      0  
Iptc.Application2.TimeCreated                String      0  

#3 Updated by Robin Mills over 1 year ago

  • Category changed from makernote to withdrawn
  • Status changed from New to Closed
  • Assignee set to Alan Pater
  • % Done changed from 0 to 100
  • Estimated time set to 2.00

Gentlemen:

I'm going to close this. This has is a very old issue and there's very little information here to enable investigation. I'm closing v0.26. I don't feel there's any merit in deferring this to v0.27 as there's insufficient information.

Also available in: Atom PDF

Redmine Appliance - Powered by TurnKey Linux