Bug #812

Exiv2 destroys hard links

Added by Andreas Huggel about 5 years ago. Updated almost 5 years ago.

Status:ClosedStart date:06 Feb 2012
Priority:HighDue date:
Assignee:Andreas Huggel% Done:

100%

Category:basicio
Target version:0.23

Description

See http://dev.exiv2.org/boards/3/topics/1103

Reported by Anders Kamf

Associated revisions

Revision 2658
Added by Andreas Huggel about 5 years ago

#812: Don't destroy files when checking if they are writable; use a memory buffer instead of a temporary file when writing files with hard links to preserve the links.

Revision 2660
Added by Andreas Huggel about 5 years ago

#812: Added function to determine the number of hard links on Windows NTFS. (Thomas Beutlich)

Revision 2688
Added by Andreas Huggel about 5 years ago

#812: Changed LoadLibrary to LoadLibraryA (Thomas Beutlich).

Revision 2689
Added by Andreas Huggel about 5 years ago

#812: Tweak to make the code compile with MSYS/MinGW.

Revision 3630
Added by Robin Mills about 2 years ago

#1043 and #1042. Thanks to Thomas for showing that r3627 reintroduced #812. Thanks to Thoralf for suggesting msync MemIo fix.

Revision 3631
Added by Robin Mills about 2 years ago

#1042 #1043 #812 Added test regression detectors

Revision 3635
Added by Robin Mills about 2 years ago

#1043 #1042 #812. Thank You to Thomas for this "polishing" patch. Thank you to everybody who has worked on this issue. Adding all the comments on the three issues together comes to about 60 items by at least 6 contributors. And it involves platform issues, networking, Linux and Windows APIs. One of the most complex issues to arise in Exiv2. Well done everybody. And we've dealt with this quickly. Only 9 days since Calvin first reported #1042.

I use the term "complex" to mean many threads of technology. "complex" != "complicated". "complicated" = "difficult to understand". We try to avoid "complicated".

History

#1 Updated by Andreas Huggel about 5 years ago

  • Status changed from Assigned to Resolved

#2 Updated by Andreas Huggel about 5 years ago

  • % Done changed from 0 to 100

#3 Updated by Andreas Huggel almost 5 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF

Redmine Appliance - Powered by TurnKey Linux