Bug #744

Regression: can’t get a section’s description in 0.21

Added by Olivier Tilloy almost 7 years ago. Updated over 1 year ago.

Status:ClosedStart date:02 Dec 2010
Priority:NormalDue date:
Assignee:Robin Mills% Done:

100%

Category:withdrawnEstimated time:1.00 hour
Target version:0.26

Description

Prior to 0.21, the Exiv2::ExifTags namespace exposed a sectionDesc(…) function to get the description of a section.
In 0.21, this function disappeared. However, the information is still there (sectionInfo in tags.cpp), but not exposed in the API.

Is there a good reason for this regression, or can this function be added back?

History

#1 Updated by Andreas Huggel almost 7 years ago

Indeed, that function is missing.

IIRC at one point during the 0.21 development cycle I was about to remove the entire "section" concept, thinking nobody needs it. Don't remember why that was only done halfway, maybe I realized exiv2 itself needs it somewhere. I'll use this issue to sort this out.

Do you know of any client that cares about this functionality?

#2 Updated by Olivier Tilloy almost 7 years ago

pyexiv2 ≥ 0.2 exposes it in its API (http://tilloy.net/dev/pyexiv2/api.html#pyexiv2.exif.ExifTag.section_description). I can’t tell whether clients rely on it or not though…
My (wild) guess is that it’s not very useful information so it wouldn’t be missed too much, but you never know.

I suppose it wouldn’t imply too much work introducing it back in the API, especially since the information is there already, and probably the translations as well. That of course depends on your plans: if it doesn’t fit with the API changes you have in mind for future versions of exiv2, it may as well be better removing the whole section concept altogether. I’d need to make it clear in pyexiv2’s documentation, but that’s no big deal.

#3 Updated by Robin Mills about 2 years ago

  • Target version set to 53

#4 Updated by Robin Mills about 2 years ago

This API uses Exiv2::Internal::IfdId which is defined in src/tags_int_hpp. Nobody else has mentioned this in the last 5 years and I think this should be closed.

#5 Updated by Robin Mills over 1 year ago

  • Status changed from New to Assigned
  • Assignee set to Robin Mills

This issue has been in the database for 5 years and nobody else has requested progress with this matter. So, unless you engage to persuade me to keep this matter alive, it will be closed on April 30 as "no longer needed/wanted".

#6 Updated by Robin Mills over 1 year ago

  • Category changed from exif to withdrawn
  • Status changed from Assigned to Closed
  • Target version changed from 53 to 0.26
  • % Done changed from 0 to 100
  • Estimated time set to 1.00

Also available in: Atom PDF

Redmine Appliance - Powered by TurnKey Linux