Bug #740

Error: Offset of directory Sony1, entry 0x2001 is out of bounds: Offset = 0x004a805e; truncating the entry

Added by Ward V about 7 years ago. Updated about 2 years ago.

Status:ClosedStart date:12 Nov 2010
Priority:NormalDue date:
Assignee:Robin Mills% Done:

100%

Category:not-a-bug
Target version:0.26

Description

This is what exiv2 says with the latest release from SVN. It's just a warning apparently, full output for the photo is:
Error: Offset of directory Sony1, entry 0x2001 is out of bounds: Offset = 0x004a805e; truncating the entry
File name : .../dsc00242.jpg
File size : 5537792 Bytes
MIME type : image/jpeg
Image size : 4912 x 3264
Camera make : SONY
Camera model : SLT-A55V
Image timestamp : 2010:11:12 18:56:20
Image number :
Exposure time : 1/40 s
Aperture : F5
Exposure bias : 0 EV
Flash : No, compulsory
Flash bias : 0 EV
Focal length : 45.0 mm (35 mm equivalent: 67.0 mm)
Subject distance:
ISO speed : 1600
Exposure mode : Auto
Metering mode : Multi-segment
Macro mode :
Image quality : Fine
Exif Resolution : 4912 x 3264
White balance : Auto
Thumbnail : image/jpeg, 16716 Bytes
Copyright :
Exif comment :

I've attached the photo with the bug. This is from a new Sony SLT-A55V, and every single photo (jpg, 'fine' quality) shows this error.

dsc00242.jpg (5.28 MB) Ward V, 12 Nov 2010 19:38


Related issues

Related to Exiv2 - Bug #1105: exiv2 output is inconsistent and seemingly random 1% of t... Closed 13 Aug 2015

History

#1 Updated by Robin Mills over 2 years ago

Here's the explanation:
http://sourceforge.net/p/darktable/mailman/message/29000541/

Another issue relating to this has surfaced: #1105

#2 Updated by Robin Mills over 2 years ago

This case can be closed as "Not a bug".

Although the message "Error: Offset of directory Sony1" is reproduced by the test file in #1105, that is a coincidence. #1105 has been resolved to a pipe buffering issue involving grep.

Workaround: This issue is caused by a violation of the Exif spec by which Sony are improperly referencing data in the image file from the maker notes. exiv2 issues a warning and ignores the data. So, the warning is benign. For Ward, who is experiencing this with every file from his camera, the workaround is to use exiv2 -q.

For the sake of completeness, here is the message at http://sourceforge.net/p/darktable/mailman/message/29000541/

Hi everyone,

It turns out this offset-out-of-bounds message originates from the Exiv2 library.

According to Andreas Huggel (the main developer of Exiv2):

That's probably a shortcoming of Exiv2: It reads from JPEGs only what is officially the Exif segment and parses that. According to the Exif specification that is a self-contained block of information, however, some Makernotes contain pointers to locations outside of the Exif segment and the error that you encountered is generated if Exiv2 comes across such a pointer. It won't affect all the other information that Exiv2 reads from the Exif segment. It also doesn't happen in RAW files as these usually do not contain an Exif section and Exiv2 accesses the entire RAW image if necessary. It can however potentially mean that modifying the Exif data of such an image with Exiv2 will corrupt this part of the Makernote (the pointer may not be correct anymore after writing); that's the reason why the error is issued.

Unless you're a programmer and willing to improve how Exiv2 works in the described case, there is nothing you need to do about this. If the error bothers you, you can suppress it with the -q flag.

Cheers,
Jeroen

#3 Updated by Robin Mills about 2 years ago

  • Category set to not-a-bug
  • Status changed from New to Closed
  • Assignee set to Robin Mills
  • Target version set to 0.26

#4 Updated by Robin Mills about 2 years ago

  • % Done changed from 0 to 100

Also available in: Atom PDF

Redmine Appliance - Powered by TurnKey Linux