Bug #633

editing via symlink does not work as expected

Added by Vladimir Nadvornik over 8 years ago. Updated over 8 years ago.

Status:ClosedStart date:16 May 2009
Priority:NormalDue date:
Assignee:-% Done:

100%

Category:-
Target version:0.18.2

Description

nadvornik@sphinx2:~/test> ll
total 3884
rw-r--r- 1 nadvornik users 3970584 May 16 09:57 1.jpg
lrwxrwxrwx 1 nadvornik users 5 May 16 09:55 1l.jpg > 1.jpg
nadvornik@sphinx2:~/test> exiv2 -M "set Exif.Image.Orientation 3" 1l.jpg
nadvornik@sphinx2:~/test> ll
total 3884
-rw-r--r-
1 nadvornik users 0 May 16 09:58 1.jpg
rw-r--r- 1 nadvornik users 3970584 May 16 09:58 1l.jpg

At least it should not destroy the original.

Associated revisions

Revision 1795
Added by Andreas Huggel over 8 years ago

#633: Fixed FileIo::transfer to operate on the linked-to file if the FileIo is a symlink. Only tested on Linux.

Revision 1796
Added by Andreas Huggel over 8 years ago

#633: Apply the fix only for platforms which have lstat. This does not include Win based platforms.

History

#1 Updated by Andreas Huggel over 8 years ago

We've seen that before, but couldn't reproduce it: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=466944

I'll try again, but would appreciate if you can investigate what's going wrong.

#2 Updated by Andreas Huggel over 8 years ago

I can reproduce it now.

Looks like it only happens if the file size is > 1M (probably because of the optimization in FileIo::temporary() )

I can take care of it now, thanks.

#3 Updated by Andreas Huggel over 8 years ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100

Now also compiles on MSVC 9 and MinGW.

#4 Updated by Andreas Huggel over 8 years ago

This looks like another Debian bug for the same problem: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=511273

#5 Updated by Andreas Huggel over 8 years ago

  • Target version deleted (0.18.1)

#6 Updated by Andreas Huggel over 8 years ago

  • Target version set to 0.18.2

#7 Updated by Andreas Huggel over 8 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF

Redmine Appliance - Powered by TurnKey Linux