Bug #568

[svn r.1571] exiv2 -ps crash for some jpeg files.

Added by Aurelien Grimaud almost 9 years ago. Updated over 8 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Andreas Huggel% Done:

100%

Category:metadata
Target version:0.18

Description

some of my jpeg makes exiv2 crash, this leads to gwenview crash ...

Here is the command output
exiv2 20080804.lundi.04.ao

20080807.jeudi.07.ao (395 KB) Redmine Admin, 05 Sep 2008 08:55


Related issues

Duplicated by Exiv2 - Bug #573: Crash in ExifData::getThumbnail () with corrupt jpeg Closed

History

#1 Updated by Andreas Huggel almost 9 years ago

Aurelien,

Can you please attach or send me one of these images?

Thanks,
Andreas

#2 Updated by Andreas Huggel almost 9 years ago

Alternatively, please retest with rev 1572, this should fix the problem.
-ahu.

#3 Updated by Andreas Huggel almost 9 years ago

To recreate the problem with rev 1571, running exiv2 -et on one of the faulty images should crash it nicely.
The problem is that the image contains corrupted thumbnail tags, in particular, Exif.Thumbnail.Compression has an empty value, and exiv2 internally tried to access the value without checking.

#5 Updated by Aurelien Grimaud almost 9 years ago

Works fine with r1572.
Thanks.
I'll just try and change exif datas in order for gwenview to not crash.

exiv2 -et 20080807.jeudi.07.ao

#6 Updated by Andreas Huggel over 8 years ago

  • % Done changed from 0 to 100

#7 Updated by Andreas Huggel over 8 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF

Redmine Appliance - Powered by TurnKey Linux