Bug #567

Windows build is broken

Added by Robin Mills over 9 years ago. Updated almost 9 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Robin Mills% Done:

100%

Category:build
Target version:0.18

Description

The information in exiv2/README about the Windows build is incorrect.

I am unable to build release and debug versions of exiv2.lib I have described these issues and my solution at http://clanmills.com/articles/gpsexiftags/windows.shtml

I have made modifications to 3 of the project files and I believe this solves the issues. As well as testing this on my machines using VC7.1 and VC8, another developer in New Zealand has successfully built using my files with VC8/Express. The project files to be replaced are:

exiv2\msvc\exiv2\exiv2.vcproj
exiv2\msvc\exiv2lib\exiv2lib.vcproj
exiv2\msvc\xmpsdk\xmpsdk.vcproj

If anyone would like to test/verify my files that be very helpful. If they seem to be OK, I'll work with Andreas to have them submitted to the SVN depot.

vcprojects.zip (4.97 KB) Redmine Admin, 17 Aug 2008 23:46

History

#1 Updated by Andreas Huggel over 9 years ago

Additional information from Chris on some inadequacies of the Windows build:
http://docs.google.com/View?docid=dcgcknkj_25dwc273fn

#2 Updated by Andreas Huggel over 9 years ago

Robin,
Thanks for offering to help out with this one!

Andreas

#3 Updated by Andreas Huggel almost 9 years ago

  • Target version set to 0.18

#4 Updated by Andreas Huggel almost 9 years ago

  • Status changed from Assigned to Resolved

#5 Updated by Andreas Huggel almost 9 years ago

  • % Done changed from 0 to 100

#6 Updated by Andreas Huggel almost 9 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF

Redmine Appliance - Powered by TurnKey Linux