Bug #554

Debian Bug report logs - #426274 exiv2: Setting "Exif.Image.DateTime Date" gives "Value too large" exception

Added by Mark Purcell almost 10 years ago. Updated over 9 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Andreas Huggel% Done:

100%

Category:exif
Target version:0.18

Description

Forwarded: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=426274

I can reproduce with exiv2 0.17:
$ exiv2 -M"set Exif.Image.DateTime Date 2007-05-27" 100.jpg
Exiv2 exception in modify action for file 100.jpg:
Entry::setValue: Value too large (tag=306, size=64, requested=8)

Additional information:

From: Benjamin Mesing <>
To: Debian Bug Tracking System <>
Subject: exiv2: Setting "Exif.Image.DateTime Date" gives "Value too large" exception
Date: Sun, 27 May 2007 18:09:40 +0200

Package: exiv2
Version: 0.10-1.4
Severity: important

I get the following result on trying to set the date:

  1. exiv2 -M"set Exif.Image.DateTime Date 2007-05-27" 000_0764.JPG
    Exiv2 exception in modify action for file 000_0764.JPG:
    Entry::setValue: Value too large (tag=306, size=64, requested=8)

Regards Ben

-- System Information:
Debian Release: 4.0
APT prefers stable
APT policy: (500, 'stable'), (50, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)
Shell: /bin/sh linked to /bin/bash
Kernel: Linux 2.6.18-3-amd64
Locale: LANG=en_GB.UTF-8, LC_CTYPE=de_DE.UTF-8 (charmap=UTF-8) (ignored: LC_ALL set to en_GB.UTF-8)

Versions of packages exiv2 depends on:
ii libc6 2.3.6.ds1-13 GNU C Library: Shared libraries
ii libexiv2-0.10 0.10-1.4 EXIF/IPTC metadata manipulation li
ii libgcc1 1:4.1.1-21 GCC support library
ii libstdc++6 4.1.1-21 The GNU Standard C++ Library v3

exiv2 recommends no packages.

-- no debconf information


Related issues

Related to Exiv2 - Feature #462: Support TIFF format Closed

History

#1 Updated by Andreas Huggel almost 10 years ago

The command is invalid, although the error message is admittedly not helpful.
The root cause of the problem is that an Exif key ('Exif.Image.DateTime') is used with a type for IPTC keys ('Date'). See exiv2(1).
Use an Exif type instead; the correct type for 'Exif.Image.DateTime' is 'Ascii' (and the correct format is '2003:12:14 12:01:44', but Exiv2 doesn't mind if it's a different Exif type or a different format)

#2 Updated by Andreas Huggel almost 10 years ago

This is a good test case for the new Exif parser in the upcoming 0.18 release though: That doesn't complain and writes a corrupted Exif section for now...

#3 Updated by Andreas Huggel over 9 years ago

r1551

The new Exif parser now also catches this case and provides a proper error message:

ahuggel@kelana> exiv2 -M"set Exif.Image.DateTime Date 2007-05-27" ./exiv2-empty.jpg
Error: 'Date' is not a valid Exif (TIFF) type; using type 'Undefined'.
ahuggel@kelana> ./exiv2 -ph exiv2-empty.jpg
0x0132 Image DateTime Undefined 8 8
0000 32 30 30 37 30 35 32 37 20070527

#4 Updated by Andreas Huggel over 9 years ago

  • % Done changed from 0 to 100

#5 Updated by Andreas Huggel over 9 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF

Redmine Appliance - Powered by TurnKey Linux