Bug #528

typeSize is meant for Exif metadata only

Added by Andreas Huggel over 9 years ago. Updated over 8 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Andreas Huggel% Done:

100%

Category:miscellaneous
Target version:0.18

Description

Metadatum::typeSize doesn't make sense for IPTC and XMP tags.
The current implementation of TypeInfo::typeSize gives wrong results if called for an Exif tag with a non-Exif (unknown) type-id.

Additional information:

r1205 introduced the XMP type LangAlt. Because its typesize is set to 1, the regression test for bug 495 now fails. This happens because the typesize of the new XMP type is used to calculate the size of a tag which happens to have Exif type 17.

History

#1 Updated by Andreas Huggel almost 9 years ago

r1551

Introduced proper TiffType, which is used in the new Exif parser. All TIFF types (values 0x0000 - 0xffff) are now a reserved subset of Exiv2 types. Type size was not changed, it is a secondary issue, the main problem was that TypeId 17 was an Exiv2 XMP type but also a possible value for a TIFF type.

#2 Updated by Andreas Huggel over 8 years ago

  • % Done changed from 0 to 100

#3 Updated by Andreas Huggel over 8 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF

Redmine Appliance - Powered by TurnKey Linux